On Mon, 24 Nov 2008 22:25:00 +0200
"Petri Helin" <[EMAIL PROTECTED]> wrote:

> On Mon, Nov 24, 2008 at 9:44 PM, Tony Houghton <[EMAIL PROTECTED]> wrote:
> >
> > Is there a patch that will work with 1.6.0? It'll make things rather
> > easier if I can just patch the debian packages instead of completely
> > replacing them.
> http://www.linuxtv.org/pipermail/vdr/2008-March/016227.html

Thanks; I used the second one (without s2api) and it applied cleanly to
the debian 1.6.0 source.

I'm having trouble with playback though. I found "In The Night Garden"
playing on BBC HD and tried testing with that. With vdr-sxfe the picture
was mostly OK but very jerky while the sound was hopeless, mostly
silence with a click or brief snatch of recognisable sound every few
seconds. Then I made a recording and tried playing it in mplayer, but
that couldn't make sense of the file at all, even with -demuxer lavf:

: ~ $ mplayer -demuxer lavf -identify '/home/tony/001.vdr' 
: MPlayer dev-SVN-r26940
: CPU: Intel(R) Core(TM)2 CPU          6400  @ 2.13GHz (Family: 6, Model: 15, 
Stepping: 2)
: CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
: Compiled with runtime CPU detection.
: Can't open joystick device /dev/input/js0: No such file or directory
: Can't init input joystick
: mplayer: could not connect to socket
: mplayer: No such file or directory
: Failed to open LIRC support. You will not be able to use your remote control.
: Playing /home/tony/001.vdr.
: libavformat file format detected.
: [lavf] Video stream found, -vid 0
: [lavf] Audio stream found, -aid 1
: VIDEO:  [mpg2]  0x0  0bpp  90000.000 fps    0.0 kbps ( 0.0 kbyte/s)
: ID_FILENAME=/home/tony/001.vdr
: ID_VIDEO_FPS=90000.000
: ID_LENGTH=249.63
: ==========================================================================
: Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough
: VDecoder init failed :(
: Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
: Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)
: ==========================================================================
: ID_VIDEO_CODEC=ffmpeg2
: ==========================================================================
: Opening audio decoder: [mp3lib] MPEG layer-2, layer-3
: Too many video packets in the buffer: (1 in 497662055 bytes).
: Maybe you are playing a non-interleaved stream/file or the codec failed?
: For AVI files, try to force non-interleaved mode with the -ni option.
: ADecoder init failed :(
: ADecoder init failed :(
: Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders

etc etc

Gxine had more success with the recording, but was pretty much the same
as vdr-sxfe. It identified the stream as 1440x1080 H.264 video and MPEG
audio layer 2. With only one decoding thread enabled there are loads of
error messages like this:

: [h264 @ 0x7f1d69f8f5a0]concealing 5040 DC, 5040 AC, 5040 MV errors

I guess that's a performance issue, because with multithreading enabled
gxine used most of the CPU power available in both cores, but not all of
it, and the above message appeared only once. Video playback was much
smoother but the audio was still as described above.

MPlayer is Christian Marillat's debian package 1:1.0.rc2svn20080706-0.1.
Do I need a newer version or a patch for VDR HD recordings? My xine
packages are all the plain debian unstable ones. Does libxine or vdr's
xineliboutput need a patch?

TH * http://www.realh.co.uk

vdr mailing list

Reply via email to