Hi

I'm running 2x DVB-C + CI/CAMS and getting intermittant channel not available messages:


I'm running 2.6.27.41-170.2.117.fc10.x86_64 with a recent v4l-dvb. In the past when I've had these problems, I've been able to fix by adding some
msleep(1);
statements in v4l-dvb/linux/drivers/media/dvb/dvb-core/dvb_ca_en50221.c

But it's still doing it.

If I switch back and forth between channels and devices (using femon) I can get the channel to work on both cards/CAMs.

Any ideas?




Apr 27 22:06:06 freddy vdr: [11775] switching to channel 1
Apr 27 22:06:06 freddy vdr: [11775] buffer stats: 81216 (3%) used
Apr 27 22:06:06 freddy vdr: [11775] info: Channel not available!
Apr 27 22:06:08 freddy vdr: [11775] CAM 2: Menu ------------------
Apr 27 22:06:08 freddy vdr: [11775] CAM 2: 'AlphaCrypt'
Apr 27 22:06:08 freddy vdr: [11775] CAM 2: 'You are not entitled'
Apr 27 22:06:08 freddy vdr: [11775] CAM 2: 'to receive this programme !'
Apr 27 22:06:08 freddy vdr: [11775] CAM 2: 'Press OK'
Apr 27 22:06:17 freddy vdr: [11775] switching to channel 1
Apr 27 22:06:17 freddy vdr: [11775] info: Channel not available!
Apr 27 22:06:56 freddy vdr: [11775] closing SVDRP connection
Apr 27 22:07:03 freddy vdr: [11775] switching to channel 1
Apr 27 22:07:03 freddy vdr: [15407] transfer thread started (pid=11775, tid=15407) Apr 27 22:07:03 freddy vdr: [15408] receiver on device 1 thread started (pid=11775, tid=15408) Apr 27 22:07:03 freddy vdr: [15409] TS buffer on device 1 thread started (pid=11775, tid=15409)
Apr 27 22:07:06 freddy vdr: [11775] switching to channel 1
Apr 27 22:07:06 freddy vdr: [15407] transfer thread ended (pid=11775, tid=15407)
Apr 27 22:07:06 freddy vdr: [11775] buffer stats: 77268 (3%) used
Apr 27 22:07:06 freddy vdr: [15410] transfer thread started (pid=11775, tid=15410) Apr 27 22:07:06 freddy vdr: [15409] TS buffer on device 1 thread ended (pid=11775, tid=15409)
Apr 27 22:07:06 freddy vdr: [15408] buffer stats: 76892 (3%) used
Apr 27 22:07:06 freddy vdr: [15408] receiver on device 1 thread ended (pid=11775, tid=15408) Apr 27 22:07:06 freddy vdr: [15411] receiver on device 1 thread started (pid=11775, tid=15411) Apr 27 22:07:06 freddy vdr: [15412] TS buffer on device 1 thread started (pid=11775, tid=15412)
Apr 27 22:07:07 freddy vdr: [15410] setting audio track to 1 (0)



_______________________________________________
vdr mailing list
vdr@linuxtv.org
http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

Reply via email to