Funny, I tried to change my system to Archlinux last weekend and had the same 
problem.  I gave up in the end and will try Opensuse 11.3 now.  I also tried 
recompiling glibc from source but it gave the same error.  Would be  to have a 
test suite for pthread.  Could be a 64bit problem... if I was going to pursue 
it I would create a test program that made the same call as vdr to submit to 
the Archlinux guys.

Sent from my HTC

----- Reply message -----
From: "David Spicer" <>
Date: Thu, Jan 6, 2011 20:53
Subject: [vdr] vdr segfaults with glibc 2.12.2
To: <>


I'm not a programmer and I'm not sure where to go with this but I 
thought that I'd try here first.  I'm running vdr 1.6.0-2 on Arch Linux 
x86_64.  The Arch glibc package was upgraded from 2.12.1 to 2.12.2 
recently, with associated toolchain package updates.  After the upgrade, 
vdr started segfaulting when it was run so I recompiled it with 
debugging symbols and got the following backtrace from gdb:

(gdb) bt
#0  0x0000000000000001 in ?? ()
#1  0x00000000004f2d06 in ?? ()
#2  0x00007fff1bb0269f in ?? ()
#3  0x00000000004c2775 in cRwLock::Lock (this=0x72bb40, Write=true, 
TimeoutMs=<value optimized out>) at thread.c:163
#4  0x000000000047d382 in cSchedulesLock::cSchedulesLock 
(this=0x7fff1bb0269f, WriteLock=<value optimized out>, TimeoutMs=<value 
optimized out>) at epg.c:911
#5  0x000000000047dd06 in cSchedules::Read (f=0x0) at epg.c:1014
#6  0x00000000004cc304 in main (argc=<value optimized out>, argv=<value 
optimized out>) at vdr.c:604

If I've done this properly then problem seems to be with the glibc, 
specifically pthread, functions that vdr uses to lock the epg data file 
for reading and writing but I have no idea whether the problem is with 
the vdr code or with glibc.  The only workaround I have at the moment is 
to downgrade to glibc 2.12.1, after which vdr works again.

Can anybody help please?


David Spicer

vdr mailing list

Reply via email to