On 16.02.2011 20:36, VDR User wrote:
On Wed, Feb 16, 2011 at 6:48 AM, Jouni Karvo<jouni.ka...@iki.fi>  wrote:
I don't know where to start.  Is this a vdr, lirc or a driver problem, or
perhaps initscript order problem?  Should I try the 2.6.38-rc5, or would
that be just looking for trouble?
Check the VDR log and xine log.  If VDR has a problem starting, you
should be able to find out why in it's log.  And if it's xine related,
you then check the xine log..  And so on..  Just follow the crumbs
until you find the problem.  Shouldn't be too hard.


:)

That was done already: vdr -l 3, xine --verbose=2; there is no hint on syslog or console output - except this, on the main thread:

Feb 17 16:48:57 vdr vdr: [3956] TS buffer on device 1 thread started (pid=3897, tid=3956)
Feb 17 16:49:57 vdr vdr: [3897] PANIC: watchdog timer expired - exiting!

and on another occasion:

Feb 17 16:47:48 vdr vdr: [3852] cVideoRepacker: switching to MPEG1/2 mode
Feb 17 16:47:48 vdr vdr: [3852] cVideoRepacker: operating in MPEG1/2 mode
Feb 17 16:47:50 vdr vdr: [3820] EPGSearch: search timer update finished
Feb 17 16:48:48 vdr vdr: [3794] PANIC: watchdog timer expired - exiting!

I have tried to keep things simple and to use lirc from vdr, instead of from xine. I guess I have to start studying how to use the xine plugin as remote control.

Ymph - I tried to set ulimit -c unlimited, but I cannot find the core for this, found in the log:

Feb 17 16:48:48 vdr kernel: section handler[3799]: segfault at 61 ip 000000000046188d sp 00007f59275fb4f0 error 4 in vdr-prod[400000+13d000]

(vdr-prod is the name of the "production" binary of vdr in my box) is this really a segfault inside the kernel?

This segfault does not happen nearly all the watchdog-expiration cycles.

yours,
        Jouni

_______________________________________________
vdr mailing list
vdr@linuxtv.org
http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

Reply via email to