Am 28.03.2011 12:24, schrieb syrius...@no-log.org:
"L. Hanisch"<d...@flensrocker.de>  writes:

- have you considered changing the way vdr detects adapter on startup ?
    for instance vdr won't detect /dev/dvb/adapter1 if
    /dev/dvb/adapter0 does not exist. this might happen when using udev
    rules and restarting vdr while a module isn't loaded

dynamite 0.0.6 now uses udev device enumeration to detect all dvb frontends 
regardless of their numbering.
If you would like to keep an adapter from being used by vdr you can set an udev 
environment property on that device.

Hi !

Thanks a lot !
I'm using 0.0.6b and the new udev rules.
My setup is :
- first vdr (the one in production that has to be working, especially
   when i'm not @home)
   genuine vdr 1.7.17, 2 dvb-s cards, diseqc

- 2nd vdr
   dynamite vdr 1.7.17, 1 dvb-s ff card which keeps crashing + 1 dvb-t
   usb stick

It is working perfectly, i haven't tried to remove/add adapter yet.
I will do later today.

 Thanks for testing this!

Just another question:
When i decide to only use one vdr instance, i'll be needing the diseqc
trick in diseqc.conf (the one that replaces the sourcecaps patch), how
do you think it could work ?
I guess the quickest workaround would be to add a new udev param to
force the card index in vdr.

I only have DVB-C and only limited knowledge about DVB-S, Diseqc and all this stuff. But I found a description of the sourcecaps patch. When I have read and understood it, I'll get in touch with you. It seems possible to configure this via udev and solve it with a device hook. But I haven't tried it and don't know exactly how the device hooks works. (a little bit of brainstorming)

I've been having issues with udev rules to order dvb devices in the
past, instead i'm using a simple simple script that gives vdr the
correct card number.
vdr $(get-dvb-device.sh main)
"get-dvb-devices.sh main" returns "-D 1 -D 4" for example. that way
i'm sure my main vdr always uses my two stable dvb-s cards


vdr mailing list

Reply via email to