On 03/17/13 13:00, Klaus Schmidinger wrote:
On 17.03.2013 12:46, Ville Skyttä wrote:
Should probably have spoken earlier, but is there any particular reason
for the ugly and hard to read Makefile variable names LCLBLD and PLGCFG?
I suppose they're short for LOCALBUILD and PLUGINCONFIG, but why do they
have to be short for anything, it's not like we're running out of space
for their names anywhere, is it? Besides, I don't think LCLBLD describes
what its effects are very well, INPLACE would sounds better to me.
The ship may already have sailed for plgcfg in vdr.pc as it's being used
by many plugin Makefiles already, but I believe the attached patches
should be safe for 2.0.0.
I'm afraid it's too late for that.
I do not understand why it should be too late.
2.0 is not out yet.
But if they really cannot have readable names,
at least I would not provide a default, but let
the makefile issue a message that they must
be set (as I suggested in the other thread).
vdr mailing list