Hello,

softhddevice does not work terribly well if you use it with a compositor (like compiz) for your desktop environment. In yaVDR a slim window manager (openbox) is used and compositing is disabled by default in the x-server configuration:


Section "Extensions"
  Option         "Composite"    Disabled
EndSection

If you want to use vdr 2.2.0 with yaVDR 0.5, all you have to do is to use the packages from yaVDR's testing PPAs (we won't copy them to stable because the support for multiple video directories has been dropped):
sudo add-apt-repository ppa:yavdr/testing-vdr
sudo add-apt-repository ppa:yavdr/testing-xbmc
sudo add-apt-repository ppa:yavdr/testing-yavdr

Create a file for apt to prefer installation of packages from these PPAs:
--- cut ---
# /etc/apt/preferences.d/yavdr-testing

Package: *
Pin: release o=LP-PPA-yavdr-testing-vdr
Pin-Priority: 1001

Package: *
Pin: release o=LP-PPA-yavdr-testing-xbmc
Pin-Priority: 1001

Package: *
Pin: release o=LP-PPA-yavdr-testing-yavdr
Pin-Priority: 1001

--- cut ---

And finally run the upgrade:
sudo apt-get update && sudo apt-get dist-upgradeAm 26.10.2015 um 00:19 schrieb Teemu Suikki:
Hi!

I was recently using Yavdr with no real problems, but now I decided to
build my own VDR system on top of Linux Mint. Main reason was that
Yavdr stable still doesn't have vdr 2.2.0..

I've got everything working nicely, but I have weird "duped frames"
problem with softhhddevice. Video and audio are fine and nicely in
sync, and usually you can't see anything wrong. But fast moving
objects sometimes have "tearing" and jerky movement.

Also if I open Softhddevice stats from the VDR main menu, I see that
"duped" field increases steadily maybe 9-10 per second! "dropped" and
"missed" stays at zero usually.

There is nothing special on the log. Sometimes I get logs like this:

Oct 26 01:09:42 puucee vdr: video: slow down video, duping frame
Oct 26 01:09:42 puucee vdr: video: 22:17:22.060  +55  311   0/\ms  23+7 v-buf
Oct 26 01:10:29 puucee vdr: video: slow down video, duping frame
Oct 26 01:10:29 puucee vdr: video: 22:18:09.380  +53  285   0/\ms  26+7 v-buf

But as you can see, these are almost a minute apart, and the actual
"duped" count increased by several hundreds already during that time.
So this logged "duping" is normal a/v sync, what I see is something
different.


This is VDR 2.2.0, and quite recent softhddevice from yavdr ppa:
1:0.6.1rc1.git20150924.1231-0yavdr0~trusty

And the very same hardware worked just nicely with full yavdr install,
with vdr 2.0.x and some old version of softhddevice. Oh, and I have
nvidia GT210.




_______________________________________________
vdr mailing list
vdr@linuxtv.org
http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

Reply via email to