Hallo Lars,

thanks for your advice. I tried it, git worked fine. But compiling still ends with an issue:


root@amd8:/usr/local/src/vdr-2.2.0/PLUGINS/src/GIT# git clone git://projects.vdr-developer.org/xineliboutput.git
Nach »xineliboutput« wird geklont
remote: Counting objects: 12082, done.
remote: Compressing objects: 100% (4899/4899), done.
remote: Total 12082 (delta 8391), reused 10777 (delta 7087)
Objekte werden empfangen: 100% (12082/12082), 5.86 MiB | 5.00 MiB/s, done.
Unterschiede werden aufgelöst: 100% (8391/8391), done.
Verbundenheit wird überprüft … Fertig.

root@amd8:/usr/local/src/vdr-2.2.0/PLUGINS/src/xineliboutput# make
Makefile:109: Building inside VDR source tree
g++ -g -O3 -Wall -Werror=overloaded-virtual -Wno-parentheses -fPIC -c -D_GNU_SOURCE -DPLUGIN_NAME_I18N='"xineliboutput"' -D_REENTRANT -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -DXINELIBOUTPUT_VERSION='"1.1.0"' -Wall -I../../../include -o config.o config.c
config.c: In constructor ‘config_t::config_t()’:
config.c:706:31: error: ‘VideoDirectory’ was not declared in this scope
   strn0cpy(browse_files_dir,  VideoDirectory, sizeof(browse_files_dir));
                               ^
make: *** [config.o] Fehler 1
root@amd8:/usr/local/src/vdr-2.2.0/PLUGINS/src/xineliboutput#

It is the same as before. Do you have other ideas?

Greetings
G. Bruno

Am 14.02.2016 um 12:56 schrieb Lars Hanisch:

Hi,

Am 14.02.2016 um 11:18 schrieb g.bruno:
> Hallo Klaus,
>
> I already tried VDR version 2.2.0, but it does not run, because the VDR-plugin-xineliboutput is missing for this
> Version. The Version I used with VDR 2.1.2 does not compile.

 Have you tried the latest commits from:
 git clone git://projects.vdr-developer.org/xineliboutput.git

 It's better to fix xineliboutput as to work with old vdr versions. :)
 If you have problems with compiling xineliboutput, please ask.

At yavdr we use some patches to compile it with recent libcec versions. They are attached, look at the series files for
the order of the patches.

Lars.



_______________________________________________
vdr mailing list
vdr@linuxtv.org
http://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

Reply via email to