On Tue, Jun 21, 2016 at 2:25 PM, Joerg Bornkessel <m...@websitec.de> wrote:
> atached patch fix this problem.

It however also most likely breaks things with systemd < 230. Attached
is another approach I sent to Klaus last week, this one should be
backwards compatible.
From 0376d2e4adc38528c0cbdde759a56700bee95872 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Ville=20Skytt=C3=A4?= <ville.sky...@iki.fi>
Date: Fri, 17 Jun 2016 17:08:31 +0300
Subject: [PATCH] Fix build with systemd >= 230

libsystemd-daemon has been merged to libsystemd.
---
 Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/Makefile b/Makefile
index b90cbd2..9193cde 100644
--- a/Makefile
+++ b/Makefile
@@ -95,9 +95,9 @@ DEFINES += -DBIDI
 LIBS += $(shell pkg-config --libs fribidi)
 endif
 ifdef SDNOTIFY
-INCLUDES += $(shell pkg-config --cflags libsystemd-daemon)
+INCLUDES += $(shell pkg-config --silence-errors --cflags libsystemd-daemon || pkg-config --cflags libsystemd)
 DEFINES += -DSDNOTIFY
-LIBS += $(shell pkg-config --libs libsystemd-daemon)
+LIBS += $(shell pkg-config --silence-errors --libs libsystemd-daemon || pkg-config --libs libsystemd)
 endif
 
 LIRC_DEVICE ?= /var/run/lirc/lircd
-- 
2.5.5

_______________________________________________
vdr mailing list
vdr@linuxtv.org
https://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

Reply via email to