Using the latest git version of the femon plugin:

https://github.com/rofafor/vdr-plugin-femon

I can successfully build it for vdr-2.3.1.

With vdr-2.3.2 I get the following errors:

*** Plugin femon:
g++ -O3 -Wall -Werror=overloaded-virtual -Wno-parentheses -march=native -D__user= -D__u8=uint8_t -fPIC -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE -I/usr/include/linux/dvb -c -DPLUGIN_NAME_I18N='"femon"' -DGITVERSION='"-GIT-7bc2ff5"' -I/home/rs/vdr-2.3.2/include -o osd.o osd.c
In file included from /home/rs/vdr-2.3.2/include/vdr/config.h:20:0,
                 from /home/rs/vdr-2.3.2/include/vdr/channels.h:13,
                 from /home/rs/vdr-2.3.2/include/vdr/device.h:13,
                 from /home/rs/vdr-2.3.2/include/vdr/receiver.h:13,
                 from receiver.h:12,
                 from osd.c:18:
/home/rs/vdr-2.3.2/include/vdr/font.h:48:15: error: ‘virtual int cFont::Width() const’ was hidden [-Werror=overloaded-virtual]
   virtual int Width(void) const = 0;
               ^~~~~
osd.c:148:15: error: by ‘cFemonDummyFont::Width’ [-Werror=overloaded-virtual]
   virtual int Width(const char *sP) const { return 50; }
               ^~~~~
osd.c: In constructor ‘cFemonOsd::cFemonOsd()’:
osd.c:209:18: error: invalid new-expression of abstract class type ‘cFemonDummyFont’
      fontM = new cFemonDummyFont;
                  ^~~~~~~~~~~~~~~
osd.c:145:7: note: because the following virtual functions are pure within ‘cFemonDummyFont’:
 class cFemonDummyFont : public cFont {
       ^~~~~~~~~~~~~~~
In file included from /home/rs/vdr-2.3.2/include/vdr/config.h:20:0,
                 from /home/rs/vdr-2.3.2/include/vdr/channels.h:13,
                 from /home/rs/vdr-2.3.2/include/vdr/device.h:13,
                 from /home/rs/vdr-2.3.2/include/vdr/receiver.h:13,
                 from receiver.h:12,
                 from osd.c:18:
/home/rs/vdr-2.3.2/include/vdr/font.h:48:15: note: virtual int cFont::Width() const
   virtual int Width(void) const = 0;
               ^~~~~
cc1plus: some warnings being treated as errors
Makefile:73: recipe for target 'osd.o' failed
make[1]: *** [osd.o] Error 1

Can anyone offer assistence please?

Regards,

Richard

_______________________________________________
vdr mailing list
vdr@linuxtv.org
https://www.linuxtv.org/cgi-bin/mailman/listinfo/vdr

Reply via email to