On 02/28/2012 11:01 AM, Douglas Landgraf wrote:
On 02/28/2012 08:49 AM, Deepak C Shetty wrote:
On 02/28/2012 07:11 PM, Itamar Heim wrote:
On 02/28/2012 03:31 PM, Deepak C Shetty wrote:
On 02/28/2012 06:57 PM, Itamar Heim wrote:
On 02/28/2012 03:22 PM, Deepak C Shetty wrote:
On 02/28/2012 06:46 PM, Itamar Heim wrote:
On 02/28/2012 02:48 PM, Deepak C Shetty wrote:
I had a host managed via OE, completely working fine. Was even able to
create and run VMs off it.
I tried removing the host from the OE (put host into maint. mode and
then remove) and when i re-discover
the same host, OE just keeps seeing it as Non-responsive.

what do you mean by "re-discover"?

I just meant that i removed the host and re-added it by selecting "New"
on the Hosts tab
and putting the IP and hostname.

I am able to ssh into the host and see that none of the vdsm processes
have been started.
I tried doing "Confirm host has been rebooted" on the OE, did not
I tried putting
host into maint. mode and re-activating the host, just doesn't help

did you do any change to the host?
just removing it from engine shouldn't cause vdsm to know/care and
should work just like before.

Nothing changed on the host. In fact when i removed and added the
host back
it says everything is installed so does nothing but reboots the host,
post reboot
vdsm does not start automatically.... and host status is non-responsive
on OE

if vdsm does not start, OE is correct...
does vdsm try to start and fails (and if so, log excerpt?)

Right, but I dont see any traces of vdsm trying to start. Nothing in the
thats relevant to this. I just did chkconfig --list and don't see vdsmd
in that, could
that be the reason.

On the host I manually did `service vdsmd restart` and then everythign

you are basically saying "re-installing a host causes vdsm to not start by default". reproducing this again to make sure and opening a bug seems the right course. trying to trace the install flow to provide root cause or even a patch would help more to fix this

Are you saying that vdsmd service should start by default post reboot and its entry
should be listed as part of chkconfig --list ?

vdsm uses systemd.

Try to use chkconfig vdsm on, you will see a wrapper to systemd command.

Found this examining the vds bootstrap complete py log

2012-02-28 23:45:32,022 DEBUG deployUtil 707 _updateFileLine: return: True
2012-02-28 23:45:32,022 DEBUG    deployUtil 228 setVdsConf: ended.
2012-02-28 23:45:32,022 DEBUG deployUtil 103 ['/bin/systemctl', 'reconfigure', 'vdsmd.service']
2012-02-28 23:45:32,026 DEBUG    deployUtil 107
2012-02-28 23:45:32,026 DEBUG deployUtil 108 Unknown operation reconfigure

2012-02-28 23:45:32,026 DEBUG    deployUtil 103 ['/sbin/reboot']
2012-02-28 23:45:32,325 DEBUG    deployUtil 107

Which vdsm version are you using? If I am not wrong, I remember to see a patch for this report.. /me going to check..

From vdsm.spec:
* Sun Feb  5 2012 Dan Kenigsberg <dan...@redhat.com> -
- BZ#773371 call `vdsmd reconfigure` after bootstrap


vdsm-devel mailing list

Reply via email to