On Sun, Mar 04, 2012 at 10:29:57PM +0800, Shu Ming wrote:
> On 2012-3-4 19:29, Itzik Brown wrote:
> >Hi,
> >
> >After running the following :
> ># git clone http://gerrit.ovirt.org/p/vdsm.git
> ># cd vdsm
> ># git fetch http://gerrit.ovirt.org/p/vdsm refs/changes/95/1695/10&&  git 
> >checkout FETCH_HEAD
> ># cd ~/rpmbuild/RPMS/x86_64
> ># rpm -Uvh vdsm-4.9.4-0.95.gita6a2e31.el6.root1330852654.x86_64.rpm
> >
> >I get the following error:
> >
> >error: Failed dependencies:
> >         libvirt>= 0.9.8 is needed by 
> > vdsm-4.9.4-0.95.gita6a2e31.el6.root1330852654.x86_64
> >         libvirt-python>= 0.9.8 is needed by 
> > vdsm-4.9.4-0.95.gita6a2e31.el6.root1330852654.x86_64
> >         logrotate>= 3.8.0 is needed by 
> > vdsm-4.9.4-0.95.gita6a2e31.el6.root1330852654.x86_64
> >         qemu-img>= 2:0.12.1.2-2.227 is needed by 
> > vdsm-4.9.4-0.95.gita6a2e31.el6.root1330852654.x86_64
> >         qemu-kvm>= 2:0.12.1.2-2.227 is needed by 
> > vdsm-4.9.4-0.95.gita6a2e31.el6.root1330852654.x86_64
> >         sanlock>= 1.8 is needed by 
> > vdsm-4.9.4-0.95.gita6a2e31.el6.root1330852654.x86_64
> >         sanlock-python is needed by 
> > vdsm-4.9.4-0.95.gita6a2e31.el6.root1330852654.x86_64
> >
> >The latest libvirt version from RHEVM Beta is:
> >libvirt-0.9.4-21.el6.x86_64

That's part of RHEL-6.2, upstream Vdsm would have to run on top of RHEL-6.3.

> >
> >I have the following channels registered:
> >
> >rhel-x86_64-rhev-mgmt-agent-6-beta
> >rhel-x86_64-server-6
> >rhel-x86_64-server-6-beta
> >
> >Should I work with Fedora when  working with upstream ?
> FC16 is more popular in developing VDSM.

Yep, if you build Vdsm's rpm on Fedora you'd need its libvirt >=
0.9.6-2.

Dan.
_______________________________________________
vdsm-devel mailing list
vdsm-devel@lists.fedorahosted.org
https://fedorahosted.org/mailman/listinfo/vdsm-devel

Reply via email to