Hi,

Had some time to test some stuff again with my node not accepting a migration.

Okay the time issue is gone for now, I set the time the same manually on all 
servers. So I was sure that wouldn't be an issue.

Did a migration just now but still no luck.

Checked the logs and found the following:

On the host (FC16 and VDSM) that the VM is migrating away from I get the 
following error message in de /var/log/vdsm/vdsm.log

---
Thread-57::ERROR::2012-03-21 15:20:49,262::vm::170::vm.Vm::(_recover) 
vmId=`2b87786b-8a43-430e-877d-6f2647f6c593`::operation failed: Failed to 
connect to remote libvirt URI qemu+tls://192.168.10.78/system
Thread-57::ERROR::2012-03-21 15:20:49,526::vm::234::vm.Vm::(run) 
vmId=`2b87786b-8a43-430e-877d-6f2647f6c593`::Traceback (most recent call last):
  File "/usr/share/vdsm/vm.py", line 217, in run
    self._startUnderlyingMigration()
  File "/usr/share/vdsm/libvirtvm.py", line 443, in _startUnderlyingMigration
    None, maxBandwidth)
  File "/usr/share/vdsm/libvirtvm.py", line 483, in f
    ret = attr(*args, **kwargs)
  File "/usr/share/vdsm/libvirtconnection.py", line 79, in wrapper
    ret = f(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 971, in 
migrateToURI2
    if ret == -1: raise libvirtError ('virDomainMigrateToURI2() failed', 
dom=self)
libvirtError: operation failed: Failed to connect to remote libvirt URI 
qemu+tls://192.168.10.78/system
---

On the Node that the VM is migrating towards I get no error message in 
/var/log/vdsm/vdsm.log

Michel
_______________________________________________
vdsm-devel mailing list
vdsm-devel@lists.fedorahosted.org
https://fedorahosted.org/mailman/listinfo/vdsm-devel

Reply via email to