On 04/22/2012 06:21 PM, Shu Ming wrote:
Hi,
I am trying to upgrade my VDSM to the latest version. But it seems that
several things should be upgraded before the new version of VDSM can be
installed on fc16. I am wondering if FC16 is the recommended system for
this upgrade. Can anyone tell me if the newer version of Fedora(FC17,
FC18) are more compatible with the latest VDSM packages?


please try:
http://comments.gmane.org/gmane.comp.emulators.ovirt.vdsm.devel/640


Dependency check failed here.
-----------------------------------------------l
[root@ovirt-node2 ~]# yum install vdsm
Loaded plugins: langpacks, presto, refresh-packagekit
fedora/metalink | 9.5 kB 00:00
ovirt-engine | 1.3 kB 00:00
updates/metalink | 4.4 kB 00:00
updates | 4.5 kB 00:00
updates/primary_db | 5.9 MB 00:14
updates/group | 1.9 MB 00:04
vdsm-changes | 2.9 kB 00:00
vdsm-changes/primary_db | 5.4 kB 00:00
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package vdsm.x86_64 0:4.9.3.2-0.fc16 will be updated
---> Package vdsm.x86_64 0:4.9.6-0.109.git009bc0c.fc16 will be an update
--> Processing Dependency: vdsm-python = 4.9.6-0.109.git009bc0c.fc16 for
package: vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64
--> Processing Dependency: libvirt-python >= 0.9.10 for package:
vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64
--> Processing Dependency: lvm2 >= 2.02.95 for package:
vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64
--> Processing Dependency: libvirt >= 0.9.10 for package:
vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64
--> Processing Dependency: sanlock >= 2.1 for package:
vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64
--> Processing Dependency: ntp for package:
vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64
--> Processing Dependency: sanlock-python for package:
vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64
--> Running transaction check
---> Package ntp.x86_64 0:4.2.6p4-1.fc16 will be installed
--> Processing Dependency: ntpdate = 4.2.6p4-1.fc16 for package:
ntp-4.2.6p4-1.fc16.x86_64
---> Package sanlock-python.x86_64 0:1.9-8.fc16 will be installed
--> Processing Dependency: sanlock-lib = 1.9-8.fc16 for package:
sanlock-python-1.9-8.fc16.x86_64
--> Processing Dependency: libsanlock.so.1()(64bit) for package:
sanlock-python-1.9-8.fc16.x86_64
---> Package vdsm.x86_64 0:4.9.6-0.109.git009bc0c.fc16 will be an update
--> Processing Dependency: libvirt-python >= 0.9.10 for package:
vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64
--> Processing Dependency: lvm2 >= 2.02.95 for package:
vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64
--> Processing Dependency: libvirt >= 0.9.10 for package:
vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64
--> Processing Dependency: sanlock >= 2.1 for package:
vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64
---> Package vdsm-python.noarch 0:4.9.6-0.109.git009bc0c.fc16 will be
installed
--> Running transaction check
---> Package ntpdate.x86_64 0:4.2.6p4-1.fc16 will be installed
---> Package sanlock-lib.x86_64 0:1.9-8.fc16 will be installed
---> Package vdsm.x86_64 0:4.9.6-0.109.git009bc0c.fc16 will be an update
--> Processing Dependency: libvirt-python >= 0.9.10 for package:
vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64
--> Processing Dependency: lvm2 >= 2.02.95 for package:
vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64
--> Processing Dependency: libvirt >= 0.9.10 for package:
vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64
--> Processing Dependency: sanlock >= 2.1 for package:
vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64
--> Finished Dependency Resolution
Error: Package: vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64 (vdsm-changes)
Requires: sanlock >= 2.1
Available: sanlock-1.8-1.fc16.x86_64 (fedora)
sanlock = 1.8-1.fc16
Available: sanlock-1.9-8.fc16.x86_64 (updates)
sanlock = 1.9-8.fc16
Error: Package: vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64 (vdsm-changes)
Requires: libvirt-python >= 0.9.10
Installed: libvirt-python-0.9.6-4.fc16.x86_64 (@updates)
libvirt-python = 0.9.6-4.fc16
Available: libvirt-python-0.9.6-2.fc16.x86_64 (fedora)
libvirt-python = 0.9.6-2.fc16
Available: libvirt-python-0.9.6-5.fc16.x86_64 (updates)
libvirt-python = 0.9.6-5.fc16
Error: Package: vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64 (vdsm-changes)
Requires: lvm2 >= 2.02.95
Installed: lvm2-2.02.86-5.fc16.x86_64 (@koji-override-0/$releasever)
lvm2 = 2.02.86-5.fc16
Available: lvm2-2.02.86-6.fc16.x86_64 (updates)
lvm2 = 2.02.86-6.fc16
Error: Package: vdsm-4.9.6-0.109.git009bc0c.fc16.x86_64 (vdsm-changes)
Requires: libvirt >= 0.9.10
Installed: libvirt-0.9.6-4.fc16.x86_64 (@updates)
libvirt = 0.9.6-4.fc16
Available: libvirt-0.9.6-2.fc16.x86_64 (fedora)
libvirt = 0.9.6-2.fc16
Available: libvirt-0.9.6-5.fc16.x86_64 (updates)
libvirt = 0.9.6-5.fc16
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
[root@ovirt-node2 ~]#



_______________________________________________
vdsm-devel mailing list
vdsm-devel@lists.fedorahosted.org
https://fedorahosted.org/mailman/listinfo/vdsm-devel

Reply via email to