----- Original Message -----
> From: "Federico Simoncelli" <fsimo...@redhat.com>
> To: "Alon Bar-Lev" <alo...@redhat.com>
> Cc: vdsm-devel@lists.fedorahosted.org, "Itzik Brown" <itz...@mellanox.com>
> Sent: Thursday, September 20, 2012 1:06:53 PM
> Subject: Re: [vdsm] Problem building vdsm RPM
> 
> ----- Original Message -----
> > From: "Alon Bar-Lev" <alo...@redhat.com>
> > To: "Itzik Brown" <itz...@mellanox.com>
> > Cc: vdsm-devel@lists.fedorahosted.org
> > Sent: Wednesday, September 19, 2012 4:18:08 PM
> > Subject: Re: [vdsm] Problem building vdsm RPM
> > 
> > ----- Original Message -----
> > > From: "Itzik Brown" <itz...@mellanox.com>
> > > To: vdsm-devel@lists.fedorahosted.org
> > > Sent: Wednesday, September 19, 2012 5:12:28 PM
> > > Subject: [vdsm] Problem building vdsm RPM
> > > 
> > > 
> > > I'm trying to build vdsm from git . After make rpm I get these
> > > errors:
> > > 
> > 
> > <snip>
> > 
> > How exactly do you try to build?
> > 
> > This is what working for me:
> > 
> > $ git clone ...
> > $ cd vdsm
> > $ autoreconf -ivf
> > $ ./configure
> > $ make dist
> > $ rpmbuild -tb vdsm*.gz
> 
> The suggested way of building vdsm is:
> 
> (clone and cd vdsm)
> $ ./autogen.sh --system
> $ make rpm

No reason for the --system, as rpmbuild will execute configure with right 
settings.
Also, in most projects autogen does not run configure... this is something 
unique in vdsm I like to avoid.
If there is a problem with rpmbuild -tb tarball, we need to fix it... is there 
any?

Alon.
_______________________________________________
vdsm-devel mailing list
vdsm-devel@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-devel

Reply via email to