On Thu, Oct 18, 2012 at 11:12:39PM +0200, Peter V. Saveliev wrote:
> …
> Just to be clear: yes, I think, that getVdsCapabilities() can and should
> be optimized, but as well it has quite different meaning for different
> purposes.
> And what about capabilities «bag» — its format also can be a subject of
> a change (e.g. long int bitmask ⇒ list of literals), but the version can
> always remain the version.

We should decide NOW on the format of the capabilities «bag», and never
change it. Testing for a capability is much more reliable than checking
a version, and remembering which version had which capability.

vdsm-devel mailing list

Reply via email to