21.10.2012 09:23, Dan Kenigsberg kirjoitti:
> We should decide NOW on the format of the capabilities «bag», and never
> change it. Testing for a capability is much more reliable than checking
> a version, and remembering which version had which capability.
Ok, so what will we decide?
1. (long)int bitmask?
… vdsm.caps.CAP_DRIVES = 0x2 …
2. list of literals?
… vdsm.caps.capabilities = ["drives", …]
3. something else?
I would prefer the second way, with list of strings.
vdsm-devel mailing list