On Sun, Oct 21, 2012 at 02:26:44PM +0200, Peter V. Saveliev wrote:
> 21.10.2012 09:23, Dan Kenigsberg kirjoitti:
> <skip />
> > We should decide NOW on the format of the capabilities «bag», and never
> > change it. Testing for a capability is much more reliable than checking
> > a version, and remembering which version had which capability.
> > Dan.
> Ok, so what will we decide?
> 1. (long)int bitmask?
> … vdsm.caps.CAP_DRIVES = 0x2 …
> 2. list of literals?
> … vdsm.caps.capabilities = ["drives", …]
I believe that (2) is basically what Adam Litke has propesed earlier, and I've
'data': ['StorageDomain_30', 'StorageDomain_22', 'Sanlock', ...]}
vdsm-devel mailing list