On 08/27/2013 12:03 PM, Yaniv Bronheim wrote:
Maybe you should pass it with quotes -> vdsClient 0 glusterVolumeSizeInfoGet 
But probably that's not the issue,
Did you try to add prints in 
http://gerrit.ovirt.org/#/c/17822/5/client/vdsClientGluster.py to see where the 
segfault is raised exactly ?
No issue with vdsClient, I executed vdsm verb as below and got the same error.
        import xmlrpclib
        proxy = xmlrpclib.ServerProxy("http://localhost:54321";)
still, if you prefer to debug step by step you can use any remote debuger (as 
pycharm) and in this case its easy, as it only one process and direct flow to 
step on.
You need to check the all flow and not only the last call 
gfapi.volumeStatvfs has all the code related to loading/using libgfapi. This func is added as supervdsm method using the decorator @makePublic, which is used in /vdsm/gluster/api.py (self.svdsmProxy.glusterVolumeStatvfs(volumeName))

Will try to debug using remote debugger. Thanks for the suggestions.

If you sure it raises inside the gfapi call with the same "gv1" as input, let 
me know and I'll investigate more

Yaniv Bronhaim

----- Original Message -----
From: "Aravinda" <avish...@redhat.com>
To: vdsm-devel@lists.fedorahosted.org
Sent: Thursday, August 22, 2013 3:23:34 PM
Subject: [vdsm] Help needed to debug segfault when using ctypes


In following patch I am using ctypes to load libgfapi(GlusterFS API) to get
the Gluster volume statvfs information.

I am getting segfault when I run
vdsClient 0 glusterVolumeSizeInfoGet volumeName=gv1

But I checked as below and it is working.

cd /usr/share/vdsm
from gluster import gfapi
print gfapi.volumeStatvfs("gv1")
posix.statvfs_result(f_bsize=4096L, f_frsize=4096L, f_blocks=25803070L,
f_bfree=19130426L, f_bavail=17819706L, f_files=6553600L, f_ffree=5855876L,
f_favail=5855876L, f_flag=4096L, f_namemax=255L)

Please suggest how I can debug this issue.


vdsm-devel mailing list

vdsm-devel mailing list

Reply via email to