we only have 2 jobs (that i'm aware of) that installs vdsm:

http://jenkins.ovirt.org/view/vdsm/job/vdsm_3.3_install_rpm_sanity_gerrit/
http://jenkins.ovirt.org/view/vdsm/job/vdsm_master_install_rpm_sanity_gerrit/

i changed 3.3 to remove python-cpopen at the start of the test. 

Eyal.

----- Original Message -----
> From: "Douglas Schilling Landgraf" <dougsl...@redhat.com>
> To: "Dan Kenigsberg" <dan...@redhat.com>
> Cc: in...@ovirt.org, "Vinzenz Feenstra" <vfeen...@redhat.com>, 
> vdsm-devel@lists.fedorahosted.org, "Yaniv Bronheim"
> <ybron...@redhat.com>, ee...@redhat.com, "David Caro Estevez" 
> <dcaro...@redhat.com>
> Sent: Friday, December 6, 2013 6:55:52 AM
> Subject: Re: [vdsm] [Users] Trouble Upgrading (Fedora)
> 
> On 12/05/2013 07:09 PM, Dan Kenigsberg wrote:
> > On Thu, Dec 05, 2013 at 09:13:02PM -0500, Douglas Schilling Landgraf wrote:
> >> On 12/05/2013 08:45 AM, Vinzenz Feenstra wrote:
> >>> On 12/05/2013 01:49 PM, Dan Kenigsberg wrote:
> >>>> Joining two threads on that subject
> >>>>
> >>>> On Sun, Nov 24, 2013 at 11:32:55AM -0500, Yaniv Bronheim wrote:
> >>>>> Hey,
> >>>>>
> >>>>> ----- Original Message -----
> >>>>>> From: "Nicholas Kesick" <cybertimber2...@hotmail.com>
> >>>>>> To: "oVirt Mailing List" <us...@ovirt.org>
> >>>>>> Sent: Friday, November 22, 2013 6:55:23 PM
> >>>>>> Subject: [Users] Trouble Upgrading (Fedora)
> >>>>>>
> >>>>>> I am having trouble upgrading on Fedora 19 to 3.3.1.
> >>>>>>
> >>>>>> Two observations:
> >>>>>> 1) I can't find ovirt-engine-3.3.1, even after a yum clear all; yum
> >>>>>> update.
> >>>>>>
> >>>>>>
> >>>>>> 2) There is a dependency update circle involving
> >>>>>> python-cpopen-1.2.3-4.fc19.x86_64 and dsm-python-cpopen.x86_64
> >>>>>> 0:4.13.0-11.fc19
> >>>>> This issue is fine. Not so smoothly but we had to do that.
> >>>>> cpopen package is published as part of vdsm code in ovirt-3.3 and
> >>>>> before,
> >>>>> On master branch we require python-cpopen formal package that is
> >>>>> shipped with fedora\rhel currently .
> >>>>>
> >>>>> Each time you'll switch between newer version of current master (3.4)
> >>>>> to ovirt-3.3 or older you will notice this report
> >>>> We should break this vicious cycle.
> >>>>
> >>>> I think it was intended to simplify "upgrade" from ovirt-3.4 to
> >>>> ovirt-3.3 on Jenkins slaves. But that's plain wrong on a wider context.
> >>>> The Jenkins issue should be solved explicitly by removing python-cpopen
> >>>> when vdsm-python-cpopen has to be installed.
> >>> python-cpopen should obsolete vdsm-python-cpopen, solving OUR jenkins
> >>> issues in the released rpms.
> >>
> >> I see this loop too.
> >> python-cpopen spec obsoletes vdsm-python-cpopen, so vdsm.spec don't
> >> need to obsolete python-cpopen. Otherwise, it will generate an
> >> infinity loop during the yum update between these packages.
> >> http://gerrit.ovirt.org/#/c/22113/
> >>
> >>
> >>> Therefore +1 for solving that on jenkins
> >> +1
> >
> > Douglas, before taking your patch to the ovirt-3.3 branch, would you
> > work with infra@ to get all their ovirt-3.3 vdsm jobs remove
> > python-cpopen before attempting to install vdsm?
> 
> Sure. @infra guys, any specific person to contact to continue this talk?
> 
> --
> Cheers
> Douglas
> IRC: dougsland
> 
_______________________________________________
vdsm-devel mailing list
vdsm-devel@lists.fedorahosted.org
https://lists.fedorahosted.org/mailman/listinfo/vdsm-devel

Reply via email to