Liron Aravot has posted comments on this change.

Change subject: Define the StorageDomain.reduce API

Patch Set 7:

File vdsm/

Line 1078:     def extend(self, storagepoolID, devlist, force=False):
Line 1079:         return self._irs.extendStorageDomain(self._UUID, 
Line 1080:                                              devlist, force)
Line 1081: 
Line 1082:     def reduce(self, jobID, guid):
> Please use the same name in all layers (jobID or jobUUID or job_id).
the names are different across the layers for all the verbs as it seems - i 
added this one to match the current pattern.
Line 1083:         return self._irs.reduceStorageDomain(jobID, self._UUID, guid)
Line 1084: 
Line 1085:     def resizePV(self, storagepoolID, guid):
Line 1086:         return self._irs.resizePV(self._UUID, storagepoolID, guid)
File vdsm/storage/

Line 747:         """
Line 748:         Reduce a block-based Storage Domain by removing a device from 
Line 749: 
Line 750:         :param UUID: The UUID of the job.
Line 751:         :type UUID: UUID
> UUID -> jobUUID
Line 752:         :param sdUUID: The UUID of the storage domain that owns the 
Line 753:         :type sdUUID: UUID
Line 754:         :param guid: A block device GUID
Line 755:         :type guid: str

To view, visit
To unsubscribe, visit

Gerrit-MessageType: comment
Gerrit-Change-Id: Ic5e41b9fa2df4ffef1f3cbb9fbfc57022ffedd9a
Gerrit-PatchSet: 7
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Liron Aravot <>
Gerrit-Reviewer: Adam Litke <>
Gerrit-Reviewer: Liron Aravot <>
Gerrit-Reviewer: Nir Soffer <>
Gerrit-Reviewer: Yaniv Kaul <>
Gerrit-Reviewer: gerrit-hooks <>
Gerrit-HasComments: Yes
vdsm-patches mailing list --
To unsubscribe send an email to

Reply via email to