Nir Soffer has uploaded a new change for review.

Change subject: build: Remove build requires needed for the tests
......................................................................

build: Remove build requires needed for the tests

We are not running the tests during the build, so we don't need to pull
these packages. These packages are installed in the CI using
automation/check-patch.packages. Developers should also use the same
file for setting up a development environment.

Change-Id: I3c385b0abeb2657a26215ce5b96976cc290734bb
Signed-off-by: Nir Soffer <nsof...@redhat.com>
---
M vdsm.spec.in
1 file changed, 1 insertion(+), 55 deletions(-)


  git pull ssh://gerrit.ovirt.org:29418/vdsm refs/changes/00/65500/1

diff --git a/vdsm.spec.in b/vdsm.spec.in
index 9252530..e4806fe 100644
--- a/vdsm.spec.in
+++ b/vdsm.spec.in
@@ -57,54 +57,10 @@
 
 %{!?_licensedir:%global license %%doc}
 
-BuildRequires: cyrus-sasl-lib
 BuildRequires: python
 BuildRequires: python2-devel
-BuildRequires: python-mock
-BuildRequires: python-netaddr
-BuildRequires: python-six >= 1.9.0
 BuildRequires: rpm-build
-
-# BuildRequires needed by the tests during the build
-BuildRequires: dosfstools
-BuildRequires: genisoimage
-BuildRequires: libnl3
-BuildRequires: libselinux-python
-BuildRequires: libvirt-python
-BuildRequires: m2crypto
-BuildRequires: mom >= 0.5.5
-BuildRequires: openssl
-BuildRequires: policycoreutils-python
-BuildRequires: psmisc
-BuildRequires: PyYAML
-BuildRequires: python-cpopen >= 1.4-1
-BuildRequires: python-inotify
-BuildRequires: python-ioprocess >= 0.16.1-1
-BuildRequires: python-pthreading
-BuildRequires: qemu-img
-BuildRequires: rpm-python
-%if 0%{?with_gluster_mgmt}
-BuildRequires: python-blivet
-%endif
-BuildRequires: sanlock-python
-
-%if 0%{?with_openvswitch}
-BuildRequires: openvswitch >= 2.0.0
-%endif
-
-%if 0%{?with_python3}
-%if 0%{?rhel}
-BuildRequires: python34-nose
-BuildRequires: python34-six
-%else # fedora
-BuildRequires: python3-nose
-BuildRequires: python3-six
-BuildRequires: python3-netaddr
-BuildRequires: python3-yaml
-BuildRequires: libselinux-python3
-BuildRequires: libvirt-python3
-%endif # rhel
-%endif # support python3
+BuildRequires: systemd-units
 
 # Autotools BuildRequires
 %if 0%{?enable_autotools}
@@ -114,16 +70,6 @@
 BuildRequires: libtool
 %endif
 
-BuildRequires: systemd-units
-
-%if 0%{?rhel}
-BuildRequires: python-decorator
-%endif # rhel
-
-%if 0%{?fedora}
-BuildRequires: python2-decorator
-BuildRequires: python3-decorator
-%endif
 
 # Numactl is not available on s390[x] and ARM
 %ifnarch s390 s390x %{arm}


-- 
To view, visit https://gerrit.ovirt.org/65500
To unsubscribe, visit https://gerrit.ovirt.org/settings

Gerrit-MessageType: newchange
Gerrit-Change-Id: I3c385b0abeb2657a26215ce5b96976cc290734bb
Gerrit-PatchSet: 1
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Nir Soffer <nsof...@redhat.com>
_______________________________________________
vdsm-patches mailing list -- vdsm-patches@lists.fedorahosted.org
To unsubscribe send an email to vdsm-patches-le...@lists.fedorahosted.org

Reply via email to