On a UNIX (HP-UX) media server when I run bpclntcmd -hn <client> (and
other bp commands) it appears they're ignoring the IP specified for the
client in /etc/hosts.    


The server also exists in DNS but my nsswitch.conf clearly says to use
files (i.e. /etc/hosts) then dns.    If I run command line tests using
other tools (e.g. nslookup and ping) the IP seen for the client is the
one in /etc/hosts.   However, bpclntcmd is giving me the one from DNS.
The IPs are different because we have use a separate subnet for backup


I've done a fair amount of searching and have read this technote:



I had actually rebooted the server for another reason about an hour and
a half after I changed /etc/hosts yesterday.    According to all the
notes I found the cache should clear itself about an hour after making a
change but that didn't happen.


This morning I still saw the issue.   I tried reissuing the bpclntcmd
-clear_host_cache (new in 7.x) and bouncing NetBackup on the media
server to no avail.


Based on the above technote I have tried moving the cache directory out
and bouncing NetBackup again to no avail.


I also tried just for the hell of it stopping the pbx_exchange daemon
and restarting then bouncing NetBackup but that didn't help either.


Interestingly bpclntcmd -hn <client> on the RHEL6 Linux master returns
the correct IP from /etc/hosts file there.   Running bpclntcmd on the
client itself with various flags (e.g. -pn, -self) find the correct
master etc...


My backup is failing with a status 59 - can't connect to client and I'm
assuming it is because the media server is getting the wrong IP for the
client.   (The client has an entry in its hosts file specifying the
backup LAN IP of the media server - this is the same as it was in 6.5.4
except we were using a Windows media server then.)


P.S.  On HP-UX nslookup DOES look at /etc/hosts unlike nslookup on other
*nix flavors so please don't respond that using nslookup for /etc/hosts
isn't valid.   As noted ping also works so such an observation wouldn't
be helpful even if it weren't incorrect.   The issue isn't host name
resolution in UNIX but rather hostname resolution done by NetBackup


Jeff Lightner | UNIX/Linux Administrator | DS Waters of America, Inc |
5660 New Northside Drive, Ste 250 | Atlanta, GA 30328 
*: (Direct Dial) 678-486-3516 |*: (Cell) 678-772-0018 |
Proud partner. Susan G. Komen for the Cure.
Please consider our environment before printing this e-mail or attachments.
CONFIDENTIALITY NOTICE: This e-mail may contain privileged or confidential 
information and is for the sole use of the intended recipient(s). If you are 
not the intended recipient, any disclosure, copying, distribution, or use of 
the contents of this information is prohibited and may be unlawful. If you have 
received this electronic transmission in error, please reply immediately to the 
sender that you have received the message in error, and delete it. Thank you.
Veritas-bu maillist  -  Veritas-bu@mailman.eng.auburn.edu

Reply via email to