Hi All  --

Here you go....

 usilsunvirtual06# raidctl -l
Controller: 0
        Disk: 0.0.0
        Disk: 0.1.0

usilsunvirtual06#

Thanks Brian for responding to my post.


=]  -----Original Message-----
=]  From: [EMAIL PROTECTED] 
=]  [mailto:[EMAIL PROTECTED] On 
=]  Behalf Of Brian Wilson
=]  Sent: Thursday, April 17, 2008 12:40 PM
=]  To: Asim Zuberi
=]  Cc: veritas-vx@mailman.eng.auburn.edu
=]  Subject: Re: [Veritas-vx] Solaris 10 - Unable to 
=]  encapsulate the root drives
=]  
=]  
=]  
=]  On Apr 17, 2008, at 10:49 AM, Asim Zuberi wrote:
=]  
=]  >
=]  > Thanks Mike for your quick response. Yes, the systems are T2000s.
=]  > I checked the "/etc/vx/bin/vxroot"  script, and it 
=]  already has the 
=]  > quotes around the "$bus_drivers".
=]  >
=]  > Sample Output:
=]  >
=]  > vxroot:bus_drivers=`modinfo | grep "PCI Bus nexus driver" \
=]  > vxroot: if [ $? -eq 0 -a -n "$bus_drivers" ] ;
=]  > vxroot:         for i in $bus_drivers
=]  > vxroot:         if [ "$drv" = "pci" -a "$flag" = "no" -a -n  
=]  > "$bus_drivers" ]
=]  > vxroot:                 for i in $bus_drivers
=]  >
=]  >
=]  > What else do I need to look out for?
=]  >
=]  
=]  what's the output from raidctl -l (run as root) ?
=]  
=]  
=]  > Some more details....
=]  >
=]  > usilsunvirtual06# pkginfo -l VRTSvxvm
=]  >   PKGINST:  VRTSvxvm
=]  >      NAME:  VERITAS Volume Manager, Binaries
=]  >  CATEGORY:  system
=]  >      ARCH:  sparc
=]  >   VERSION:  4.1,REV=02.17.2005.21.28
=]  >   BASEDIR:  /
=]  >    VENDOR:  VERITAS Software
=]  >      DESC:  Virtual Disk Subsystem
=]  >    PSTAMP:  VERITAS-4.1MP2.14:2007-02-21
=]  >  INSTDATE:  Apr 06 2007 07:55
=]  >   HOTLINE:  800-342-0652
=]  >     EMAIL:  [EMAIL PROTECTED]
=]  >    STATUS:  completely installed
=]  >     FILES:      845 installed pathnames
=]  >                  23 shared pathnames
=]  >                  18 linked files
=]  >                  98 directories
=]  >                 410 executables
=]  >              300751 blocks used (approx)
=]  >
=]  >
=]  > usilsunvirtual06# cat /etc/*release*
=]  >                       Solaris 10 8/07 s10s_u4wos_12b SPARC
=]  >           Copyright 2007 Sun Microsystems, Inc.  All 
=]  Rights Reserved.
=]  >                        Use is subject to license terms.
=]  >                            Assembled 16 August 2007
=]  >
=]  > usilsunvirtual06# uname -a
=]  > SunOS usilsunvirtual06 5.10 Generic_127111-11 sun4v sparc 
=]  SUNW,Sun- 
=]  > Fire-T200
=]  >
=]  >
=]  >
=]  >
=]  >
=]  >
=]  >
=]  >
=]  > =]  -----Original Message-----
=]  > =]  From: Myers, Mike [mailto:[EMAIL PROTECTED] =]  
=]  Sent: Thursday, 
=]  > April 17, 2008 9:56 AM =]  To: 'Asim Zuberi'; 
=]  > veritas-vx@mailman.eng.auburn.edu =]  Subject: RE: [Veritas-vx] 
=]  > Solaris 10 - Unable to =]  encapsulate the root drives =] 
=]  =]  Is this 
=]  > a T1000/2000 by chance?
=]  > =]
=]  > =]  If so, you might be running into a bug in the "vxroot"
=]  > =]  script.  It's easy to check -- on line 138 is the 
=]  variable =]  
=]  > $bus_drivers quoted or not?  If it's NOT quoted, then you 
=]  =]  might 
=]  > have this bug affecting you.  The fix it is as simple =]  
=]  as putting 
=]  > quotes around it like this:
=]  > =]
=]  > =]  138c138
=]  > =]  <       if [ $? -eq 0 -a -n $bus_drivers ] ;
=]  > =]  ---
=]  > =]  >       if [ $? -eq 0 -a -n "$bus_drivers" ] ;
=]  > =]
=]  > =]  I'm sure there's an official Veritas patch somewhere 
=]  (I =]  know 
=]  > this was fixed in the 5.0 release) but I find this a =]  
=]  quicker fix.
=]  > =]
=]  > =]  Cheers,
=]  > =]   - Mike.Myers <at> nwdc.net
=]  > =]  -----Original Message-----
=]  > =]  From: [EMAIL PROTECTED]
=]  > =]  [mailto:[EMAIL PROTECTED] On 
=]  =]  Behalf 
=]  > Of Asim Zuberi =]  Sent: Wednesday, April 16, 2008 7:32 
=]  PM =]  To: 
=]  > veritas-vx@mailman.eng.auburn.edu =]  Subject: 
=]  [Veritas-vx] Solaris 10 
=]  > - Unable to encapsulate =]  the root drives =] =] =] =]  
=]  Hi All -- =] 
=]  > =]  We're unable to encapsulate the root-drives on the 
=]  Systems =]  
=]  > running Solaris 10 upgrade 4 with Veritas VM 4.1 MP2 =]  
=]  patches. All 
=]  > the required OS patches are installed on the =]  system. 
=]  Every time an 
=]  > encapsulation attempt is made using =]  "vxdiskadm" it 
=]  appears all is 
=]  > getting configured properly.
=]  > =]  But on the second reboot during the encapsulation 
=]  cycle, =]  the 
=]  > system couldn't just come-up.
=]  > =]
=]  > =]  Just wondering, if anyone has encountered the same issues?
=]  > =]  Any pointers will be a great help!
=]  > =]
=]  > =]
=]  > =]  thanks!
=]  > =]  --Asim;
=]  > =]
=]  > =]  _______________________________________________
=]  > =]  Veritas-vx maillist  -  Veritas-vx@mailman.eng.auburn.edu =]  
=]  > http://mailman.eng.auburn.edu/mailman/listinfo/veritas-vx
=]  > =]
=]  >
=]  > _______________________________________________
=]  > Veritas-vx maillist  -  Veritas-vx@mailman.eng.auburn.edu 
=]  > http://mailman.eng.auburn.edu/mailman/listinfo/veritas-vx
=]  
=]  

_______________________________________________
Veritas-vx maillist  -  Veritas-vx@mailman.eng.auburn.edu
http://mailman.eng.auburn.edu/mailman/listinfo/veritas-vx

Reply via email to