On 4/23/06, Bram Moolenaar <[EMAIL PROTECTED]> wrote: > > Yakov Lerner wrote: > > > Here is another try, less instrusive. > > We make 'received_from_client' serve both cases, the clientserver and > > the pushkeys() case, only with appropriate change in ifdefs. > > Logic of input_available() is not intruded upon now, except for ifdefs. > > OK, it seems this version is harmless so long as you don't use the > function, and probably works OK otherwise. > > Is pushkeys() really a good name? Something with "typeahead" would be > better, but probably too long.
Pushkeys() is rather effective, I thought. sendkeys() is of course another alternative, although send isn't as good as push I think. Push seems to be a common description of the action we're discussing, both used in mutt, Zsh, and screen to describe the action. How about pushinput()? Perhaps doesn't fit well together with input(), though. nikolai