On Sat, Mar 31, 2012 at 3:53 AM, Ingo Karkat <[email protected]> wrote:
> On 30-Mar-2012 21:35, Bram Moolenaar wrote:
>
>> [41 lines deleted]
>>
>> I don't think we should change the current meaning of 'cursorline'.
>> What the original poster asked for is something else.
>>
>> Since 'cursorline' is a boolean option we can't change it to be more
>> than an on/off switch.
>>
>> That leaves adding Yet Another Option...
>
> We have a similar precedent of two linked options: 'number' and
> 'relativenumber', and that seems to work fine, with one resetting the other 
> when
> set. I also like that in that case, one can set one in a window and the other 
> in
> another one, depending on what kind of text is being edited. (As we've already
> learned that cursorline is used for many different purposes.)
>
> How about naming it 'cursorscreenline', or maybe 'cursordisplayline'?
>
> -- regards, ingo
>
> --
> You received this message from the "vim_dev" maillist.
> Do not top-post! Type your reply below the text you are replying to.
> For more information, visit http://www.vim.org/maillist.php


For relativeline, I hope that we can have another setting such as
`cursorscreenline` which is really useful in tex.

-- 
You received this message from the "vim_dev" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

Raspunde prin e-mail lui