Christian Brabandt wrote:
> On Mi, 14 Feb 2018, Charles E Campbell wrote:
>
>> [D]fsp#03 cec/ xorn? gvim -u NONE -U NONE
>>
>> ** (gvim:4731): CRITICAL **: murrine_style_draw_box: assertion 'height
>>> = -1' failed
>>
>> Hello:
>>
>> However, it doesn't prevent gvim from starting up (it appears to be a
>> gtk issue, actually).
>>
>> So, I use:
>>
>> gvim -u NONE -U NONE  2> /dev/null
>>
>> so the error/warning message gets routed out-of-sight.
>>
>> Chip Campbell
>>
>> vim --version : 8.0.1520
>> O/S: Scientific Linux 7.3 (Nitrogen)
>> pkg-config --modversion gtk+-2.0 : 2.24.28
>> pkg-config --modversion gtk+-3.0 : 3.14.13
>> I also use Mate (https://mate-desktop.org/)
> Google suggests, that this is a theme problem and occurs with the 
> Ambience and Radience theme (or whatever it is called).
> Here is a fix from Ubuntu launchpad:
> https://bugs.launchpad.net/ubuntu/+source/light-themes/+bug/538499/comments/24

Well, that's interesting.  I spent a little time trying to find out what
my current gtk theme is.  I saw gtkrc mentioned several times, so I
found .gtkrc in my home directory -- and it holds the following text:

# -- THEME AUTO-WRITTEN DO NOT EDIT
include "/usr/share/themes/Bluecurve/gtk/gtkrc"
# -- THEME AUTO-WRITTEN DO NOT EDIT

However, /usr/share/themes/Bluecurve doesn't exist.  I suspect that
non-existence of the theme is responsible for those assertion messages
I've been getting.

Thanks!
Chip Campbell


-- 
-- 
You received this message from the "vim_dev" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

--- 
You received this message because you are subscribed to the Google Groups 
"vim_dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to vim_dev+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Raspunde prin e-mail lui