>  The attached patch tries to fix both warnings.

Thanks.

> It seems that the function peek_input_record_buffer() is not used anywhere. 
> So the patch removes it.

Yeah, it’s not used now.
The existing static s_irCache is inner function scoped, so I couldn’t directly 
inject records to it for testing.   Initially, I thought it would make sense 
for the new input_record_buffer to replace s_irCache.   It seems redundant 
having both – and the code could be simplified.  However, the existing “peek” 
functionality has some weird behaviour.  There is a scenario where peek could 
actually pop a record off the buffer, and I wasn’t sure if that’s a bug or 
intentional, and so Bram suggested to leave it if I’m not sure that it’s a bug. 
  I thought I might be able to come back to this later, but for now 
peek_input_record_buffer() is not used, so doesn’t need to be there.
Cheers,
Chris Plewright

-- 
-- 
You received this message from the "vim_dev" maillist.
Do not top-post! Type your reply below the text you are replying to.
For more information, visit http://www.vim.org/maillist.php

--- 
You received this message because you are subscribed to the Google Groups 
"vim_dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To view this discussion on the web visit 
https://groups.google.com/d/msgid/vim_dev/SYBP282MB2695BA7692064C57CC2F94DCDBEA9%40SYBP282MB2695.AUSP282.PROD.OUTLOOK.COM.

Raspunde prin e-mail lui