On Thu, Feb 08, 2018 at 09:47:40AM -0800, Vincent Royer wrote:
> Hi,
> When I access my vm's locally over virt-viewer on windows clients,
> everything works fine.
> When I access the same vm's over a site-to-site VPN (setup between the two
> firewalls), it fails with an error: unable to connect to libvirt with uri:
> [none].  Similarly I cannot connect in a browser vnc session.
> I can resolve the DNS of the server from my remote client due to domain
> override in the firewall, and everything else I do seems completely unaware
> of the vpn link (SSH, RDP, etc).
> Any clues would be appreciated!

You mention Windows clients at the beginning of your email, have you
tried Linux clients too?
It should be possible to get more detailed logs of what's happening with
virt-viewer on Windows, but I forgot how this is done :( maybe run it
with --verbose --debug.
On your windows client, have you tried a direct connection to a VM over
your VPN using remote-viewer.exe spice://host_ip:spice_port ?
Hopefully, experimenting with these suggestions will give more hints in
order to move forward :)


Attachment: signature.asc
Description: PGP signature

virt-tools-list mailing list

Reply via email to