Linus Torvalds wrote:

On Tue, 23 Oct 2007, Rusty Russell wrote:
Well, with that out the way, and some scatterlist fixups, please pull from

        git://git.kernel.org/pub/scm/linux/kernel/git/rusty/linux-2.6-lguest.git

Also, please add a "lguest: " prefix to all future commits.

Otherwise, in the one-line summary, it is impossible to tell what portion of the kernel is being updated:

        Use "struct boot_params" in example launcher
        Loading bzImage directly.
        Rename "cr3" to "gpgdir" to avoid x86-specific naming.
        Pagetables to use normal kernel types
        Move register setup into i386_core.c
        Accept elf files that are valid but have sections that can not
                be mmap'ed for some reason.

git tools are all keyed to use that first line as a summary of the changeset, without giving any other context whatsoever. See Linus's 2.6.X-rcY announcements, for example.

This is also described in akpm's http://www.zip.com.au/~akpm/linux/patches/stuff/tpp.txt or my http://linux.yyz.us/patch-format.html

        Jeff


_______________________________________________
Virtualization mailing list
[email protected]
https://lists.linux-foundation.org/mailman/listinfo/virtualization

Reply via email to