I am running VNC behind a LinkSys router myself.  This is what I found that
worked for me.

My setup:      Server  <=====> Router <====> ISP <=====>  Dial up ISP<=====>
               Static (192.168.x.x     Static (216.176.x.x )
DHCP (changes with each call)

This may also be a static address

It is assume that you have admin access to your router.  Open the router
control and go to the Applications & Gaming.
in the boxes that follow put the following.

                        Port Range:

Application         Start         End          Protocol              Ip
Address         Enable
VNC                  5900         5901         TCP
192.168.x.x           X
VNC Java           5800         5801         TCP
192.168.x.x           X

This will allow anyone on the internet that knows your address and password
to connect to the VNC server.
If you wish to use a reverse viewer then add the following:

Vnc View          5500         5501         UDP
192.168.x.x            X


This is what worked for me.
I checked the manual for the Linksys router befsx41 and it has the same
setup as my router.

In the column "Application" is just a name tag to identify what the port is.
The start and end  columns are the ports to be passed through
Protocol is self evident
IP address is the address of the VNC server.  This is the inside address of
your lan machine.

Example:  Internet to router ==> ( Router Wan side / Router lan
Side ==> ( Server

The enable box must be checked to activate the port forward.

It is my hope that this is of some help to you.  Please understand that I am
by no means a expert.  I just happen to
have been using a Linksys router and worked out the problems.



----- Original Message ----- 
From: "Pants Robot" <[EMAIL PROTECTED]>
Sent: Tuesday, October 19, 2004 8:34 AM
Subject: can't connect behind Linksys

> I'm behind a Linksys befsx41 router and, under the forwarding tab, am
> forwarding ports 5900 to 5900. VNC runs fine when I access it from my
> internal network (behind my router) as long as I connect to my LAN ip
> address ; but when I try to connect to my WAN ip I get "unable to
> connect to host: Connection refused (10061)".
> My filters are set to:
> Block WAN Request: Disable
> Multicast Pass Through: Enable
> IPSec Pass Through: Disable
> PPTP Pass Through: Disable
> Remote Management: Disable
> Remote Upgrade: Disable
> MTU: Auto
> I'm not sure what the problem is, Linksys Tech Support blames Comcast
> and Comcast Tech Support blames Linksys.
> Please help
> _______________________________________________
> VNC-List mailing list
> To remove yourself from the list visit:
VNC-List mailing list
To remove yourself from the list visit:

Reply via email to