Hi,

Sure I clicked on the "Jetzt- button....

@ Daniel: I used you config file (vzlogger didn't start with it because of
an error in it) but I took over your changes in my own config file and kept
my own log file....
@ Daniel, just forget about "just after reboot" (I rebooted the raspberry
to start fresh)
@ Daniel: I checked the wires and gpio ports over and over again, they are
right.

I replaced the complete raspberry pi, no difference.
Still ONLY readings from "Energie gebruik" and "Water".

Maybe it isn't allowed to have two of the same type?
[image: Inline afbeelding 1]

Again I exchanged the wires of "Energie gebruik" and "Energie opbrengst".
Then you see the sun is shining in the graphics.

[image: Inline afbeelding 2]
So the hardware is right!

Here the start of the logfile:
[Sep 17 12:12:04]       Opened logfile /var/log/vzlogger.log
[Sep 17 12:12:04][push] No pushDataServer defined.
[Sep 17 12:12:04][]     ===> Start meters
[Sep 17 12:12:04][s0]   counter_thread created
[Sep 17 12:12:04][mtr0] Meter connection established
[Sep 17 12:12:04][mtr0] Meter thread started
[Sep 17 12:12:04][mtr0] Meter is opened. Starting channels.
[Sep 17 12:12:04][chn0] Logging thread started
[Sep 17 12:12:04][s0]   counter_thread created
[Sep 17 12:12:04][mtr1] Meter connection established
[Sep 17 12:12:04][mtr1] Meter thread started
[Sep 17 12:12:04][mtr1] Meter is opened. Starting channels.
[Sep 17 12:12:04][chn1] Logging thread started
[Sep 17 12:12:04][s0]   counter_thread created
[Sep 17 12:12:04][mtr2] Meter connection established
[Sep 17 12:12:04][mtr2] Meter thread started
[Sep 17 12:12:04][mtr2] Meter is opened. Starting channels.
[Sep 17 12:12:04][chn2] Logging thread started
[Sep 17 12:12:04][s0]   Counter thread started with blocking hwif
[Sep 17 12:12:04][mtr0] Number of readers: 4
[Sep 17 12:12:04][mtr0] Config.daemon: 1
[Sep 17 12:12:04][mtr0] Config.local: 0
[Sep 17 12:12:04][chn0] Start logging thread for volkszaehler-api. Running
as daemon: yes
[Sep 17 12:12:04][chn0] Using default volkszaehler api.
[Sep 17 12:12:04][s0]   Counter thread started with blocking hwif
[Sep 17 12:12:04][mtr1] Number of readers: 4
[Sep 17 12:12:04][mtr1] Config.daemon: 1
[Sep 17 12:12:04][mtr1] Config.local: 0
[Sep 17 12:12:04][chn1] Start logging thread for volkszaehler-api. Running
as daemon: yes
[Sep 17 12:12:04][chn1] Using default volkszaehler api.
[Sep 17 12:12:04][s0]   Counter thread started with blocking hwif
[Sep 17 12:12:04][mtr0] Number of readers: 4
[Sep 17 12:12:04][mtr0] Config.daemon: 1
[Sep 17 12:12:04][mtr0] Config.local: 0
[Sep 17 12:12:04][chn0] Start logging thread for volkszaehler-api. Running
as daemon: yes
[Sep 17 12:12:04][chn0] Using default volkszaehler api.
[Sep 17 12:12:04][s0]   Counter thread started with blocking hwif
[Sep 17 12:12:04][mtr1] Number of readers: 4
[Sep 17 12:12:04][mtr1] Config.daemon: 1
[Sep 17 12:12:04][mtr1] Config.local: 0
[Sep 17 12:12:04][chn1] Start logging thread for volkszaehler-api. Running
as daemon: yes
[Sep 17 12:12:04][chn1] Using default volkszaehler api.
[Sep 17 12:12:04][s0]   Counter thread started with blocking hwif
[Sep 17 12:12:04][mtr2] Number of readers: 4
[Sep 17 12:12:04][mtr2] Config.daemon: 1
[Sep 17 12:12:04][mtr2] Config.local: 0
[Sep 17 12:12:04][chn2] Start logging thread for volkszaehler-api. Running
as daemon: yes
[Sep 17 12:12:04][chn2] Using default volkszaehler api.
[Sep 17 12:12:04][s0]   counter_thread created
[Sep 17 12:12:04][mtr3] Meter connection established
[Sep 17 12:12:04][mtr3] Meter thread started
[Sep 17 12:12:04][mtr3] Meter is opened. Starting channels.
[Sep 17 12:12:04][chn3] Logging thread started
[Sep 17 12:12:04][]     Startup done.
[Sep 17 12:12:04][s0]   Counter thread started with blocking hwif
[Sep 17 12:12:04][mtr3] Number of readers: 4
[Sep 17 12:12:04][mtr3] Config.daemon: 1
[Sep 17 12:12:04][mtr3] Config.local: 0
[Sep 17 12:12:04][chn3] Start logging thread for volkszaehler-api. Running
as daemon: yes
[Sep 17 12:12:04][chn3] Using default volkszaehler api.
[Sep 17 12:12:05][S0]   MeterS0:HWIF_GPIO:first poll returned 0
[Sep 17 12:12:05][S0]   MeterS0:HWIF_GPIO:first poll returned 0
[Sep 17 12:12:05][S0]   MeterS0:HWIF_GPIO:first poll returned 0
[Sep 17 12:12:05][S0]   MeterS0:HWIF_GPIO:first poll returned 0
[Sep 17 12:12:06][S0]   MeterS0:HWIF_GPIO:first poll returned 0


Maybe I should burn a new  image and start all over again???

Thanks in advance....


2016-09-15 18:41 GMT+02:00 Udo1 <u...@gmx.net>:

> Am 15.09.2016 um 14:42 schrieb fiets fietsenwiel:
>
>> When I change the config file so there is only one meter with GPIO22 and
>> the right UUID there are NO messurments.
>>
> Just an idea: click the 'Jetzt'-Button in the frontend and pay attention
> to the timeline.
>
>
> BR
> Udo
>

Antwort per Email an