Hallo Saftwerk,

bei dem Zinnober im PV-Forum hab ich dich fast vergessen...

am Samstag, 15. Oktober 2016 um 00:25 hast du geschrieben:
>      Spekulation: Es gibt 2 Möglichkeiten:
>      1. Die Uhr bleibt während des Stromausfalls einfach stehen und
> die     roten Zeilen werden nach PowerON aufgezeichnet.

Das mit Sicherheit, der Raspi hat eben keine Hardwareuhr die
batteriegestützt weitertickt. Das muss die Software machen. Ist der
Raspi aus gibts auch kein Ticken.

>      2. Der shutdown Befehl stiftet irgendwo Unruhe

Denke ich nicht.
Beim Raspi hab ich es noch nicht gesehen (da logg ich mich immer
übers Netz ein), aber der BananaPi meldet beim Runterfahren am Monitor
das die Uhr gesichert wird.

Das könnte bedeuten: die Sicherung wird beim start eine Stunde später
aufgerufen, der vzlogger nimmt mit dieser falschen Zeit die Arbeit auf
und wennder ntpd dann die richtige bekommt gibts den Zeitsprung.


Falls dein Raspi über WLAN kommuniziert könnte das vielleicht die
Ursache sein. Der vzlogger läuft schon bevor das Netz steht und die
Zeit aktualisiert werden konnte.
Ich meine von so einem Fall schonmal gelesen zu haben. Das
Problem konnte behoben werden indem der loggende Dienst erst mit
Verzögerung gestartet wurde.

>      Mit Plausibilitäts-Grenzen wäre vermutlich nix passiert.

Mit korrekter Systemzeit auch nicht. Ich finde halt du setzt den Hebel
an der falschen stelle an...

>      Hinweis: Nicht alle Kanäle hatten fehlerhafte Werte.

Das ist wieder so eine Nullaussage.
Welche Kanäle? Wie unterscheiden die sich von denen mit Zeitsprung?
Wenn die betreffende Kanäle z.B. übers WLAN ankommen könnte das
erklären warum sie keinen Zeitsprung machen.


mfg Daniel

Antwort per Email an