Hallo Frank,

 

danke für die schnelle Antwort.

Leider bekomme ich gar keine Antworten vom vzlogger, auch wenn ich ihm Daten 
übergebe.

 

1.      Wenn ich beispielsweise folgende Daten an vzlogger übergebe, sehe ich 
in Node-Red nichts:

python /home/pi/vzclient.py -u <UUID Sensor> add data value=15



2.      Die Daten vom Stromzähler, die Volkszähler einliest, werden doch 
generell über den vzlogger übergegben, oder täusche ich mich hier?
Diese Daten müsste ich doch ebenfalls zyklisch alle paar Sekunden in Node-Red 
empfangen.

 

Gruß

Shawn

 

 

Von: volkszaehler-users <volkszaehler-users-boun...@demo.volkszaehler.org> Im 
Auftrag von Frank Richter
Gesendet: Sonntag, 15. April 2018 12:08
An: volkszaehler.org - users <volkszaehler-users@demo.volkszaehler.org>
Betreff: Re: [vz-users] Probleme mit Push-Server Anbindung für Node-red

 

Hi,

 

möglicherweise hast du das Konzept des Push-Servers missverstanden: der läuft 
parallel zur Middleware und liefert Daten an MW und Datenbank vorbei direkt ans 
Frontend (oder eben per Websockets). Voraussetzung dafür ist, dass er auch mit 
Daten gefüttert wird. vzlogger kann das, wenn er entsprechend konfiguriert ist.

An die Daten in der DB kommst du auf diesem Weg nicht.

 

Gruß

Frank

 

Shawn <shaw...@gmx.de <mailto:shaw...@gmx.de> > schrieb am So., 15. Apr. 2018 
11:42:

Hallo zusammen,

 

ich probiere seit Tagen die Daten meines Volkszaehlers in Node-red einzulesen 
und bin der Anleitung unter https://wiki.volkszaehler.org/howto/node-red 
gefolgt.

 

In Node-red habe ich einen Websocket-Node angelegt, der wie folgt aussieht:



Hinweis: Der Volkszaehler läuft auf dem Raspberry mit der IP 192.168.1.42. 
Node-red läuft derzeit auf einem separaten Raspberry mit der IP 192.168.1.60.  
Der Websocket-Node gibt als Status „Connected“ aus.

 

 

Wenn ich den Ausgang des Websocket-Node in ein Debug-Node leite, erhalte ich 
lediglich einen Datensatz mit folgende Ausgabe:



Im Volkszaehler sollten jedoch viele Daten vorhanden sein, u.a. zwei 
Stromzähler und mehrere Temperatursensoren.

 

 

Hat jemand eine Idee, wo es hier klemmen könnte?

 

Vielen Dank schon einmal im Voraus.

 

Gruß

Shawn

 

Antwort per Email an