Getting Crystal Space and WxWidgets to talk to each other is generally one 
of the more difficult parts of the build process.  Crystal Space builds a 
"wxtest" app which you can use to verify that a) it works and b) it's 
getting the input events that you expected.  Keyboard input with Wx and 
OpenGL has been rather dodgy, although I only recall having trouble on OS 
X, not Windows.

But yea, give 0.24 a try :-)

On Tue, Feb 20, 2007 at 08:02:33PM -0800, Ken Taylor wrote:
> So as I was discussing with Peter last night on the irc/vos bridge, I got
> everything to compile right for wxterangreal except for a missing wxgl.dll.
> It turns out that this is a CrystalSpace plugin, and the CS configure needs
> to see wxwidgets in order to create it.
> Fair enough -- I added a CONFIG_WX to the configure command line (basically
> using the line from
> ) and it seemed
> to work -- according to config.log, CS configure recognizes wxwidgets now.
> But it didn't *really* work -- configure determined that wxwidgets didn't
> support openGL, and still didn't build wxgl.dll!
> Some troubleshooting in the CS configure scripts (I'm using the CS snapshot
> in CS-2006-04-15.tar.gz) and I noticed that the check for whether wx
> supports gl uses the $cs_cv_libglu_cflags,lflags, and libs. But I was pretty
> sure GLU wasn't what we wanted -- just straight openGL. And GLU isn't
> checked for in the configure script at all, so those variables are
> uninitialized! Well, long story short, I added the $cs_cv_libgl_cflags, etc
> to the configure file, ran, and re-configured. Poof! wx support
> with gl enabled!
> After running make install, I verified that wxgl.dll was built. Yup! I tried
> running my wxterangreal using it and yay! it works --- kinda? Hmm... I can't
> move my avatar around. That's strange.
> Rebuilt everything. Still can't move the avatar. On a whim, I try running it
> using the wxgl.dll included with the binary installer -- and my avatar
> moves! I go back to the wxgl.dll I built... I can't move!
> Very strange. So I guess that leaves me with 3 mysteries:
> 1) Why couldn't the CS snapshot correctly test for wx-with-gl, and why has
> it apparently worked for others in the past?
> 2) Why did the wxgl.dll built with that CS snapshot (and the wxwidgets
> snapshot from vos-win32-mingw-libs-0.23.0.tar.gz) have trouble with keyboard
> input, but the wxgl.dll included with the binary installer works fine?
> 3) Why am I still messing around with the 0.23 source instead of just moving
> on to 0.24 and forgetting about ancestral build problems? ;)
> If others want to ponder these mysteries, go ahead. As for me, I think my
> voyages with building 0.23 from scratch should end here; it's time to move
> on to better and more "bazaar" things ;)
> -Ken
> _______________________________________________
> vos-d mailing list

[   Peter Amstutz  ][ [EMAIL PROTECTED] ][ [EMAIL PROTECTED] ]
[Lead Programmer][Interreality Project][Virtual Reality for the Internet]
[ VOS: Next Generation Internet Communication][ ]
[ ][ pgpkey:  18C21DF7 ]

Attachment: signature.asc
Description: Digital signature

vos-d mailing list

Reply via email to