I was thinking of renaming "MetaObject" to "Component". Same concept, just a name that reflects a more standard usage. Also "metaobject" is an existing term of art in the programming language community having to do with defining and manipulating the semantics of how programming language objects are invoked, and while this is something that will exist in VOS, the current "MetaObject" class isn't it.
Comments? -- [ Peter Amstutz ][ [EMAIL PROTECTED] ][ [EMAIL PROTECTED] ] [Lead Programmer][Interreality Project][Virtual Reality for the Internet] [ VOS: Next Generation Internet Communication][ http://interreality.org ] [ http://interreality.org/~tetron ][ pgpkey: pgpkeys.mit.edu 18C21DF7 ]
Description: Digital signature
_______________________________________________ vos-d mailing list firstname.lastname@example.org http://www.interreality.org/cgi-bin/mailman/listinfo/vos-d