Edwin Whitelaw <edwin.white...@...> writes: > > I'm trying to turn off DMA for 0.6 on a WRAP board with > > kernel /vmlinuz root=LABEL=ROOT_FS console=ttyS0,38400n8 ide=nodma > > but the errors (and lengthy boot time) still persist. > > Am I missing something? > > Edwin >
I've hit the same issue on a Soekris 4801 with Voyage 0.6.1. I found the following debian bug report (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=478317) provided the solution. e.g. remountrw echo 'options ide_core options="ide=nodma"' > /etc/modprobe.d/ide update-initramfs -u remountro reboot It seems the issue is that options on the command line (via grub) aren't used when modules are loaded from the initrd so you need to update the initrd to include the options. Dylan _______________________________________________ Voyage-linux mailing list [email protected] http://list.voyage.hk/mailman/listinfo/voyage-linux
