Hi Ed,

Works fine for centos now. Remove of dpdk packages for opensuse is missing in 
patch.

Thanks,
Matus

From: Ed Kern (ejk)
Sent: Tuesday, March 13, 2018 7:00 PM
To: Matus Fabian -X (matfabia - PANTHEON TECHNOLOGIES at Cisco) 
<matfa...@cisco.com>
Cc: vpp-dev@lists.fd.io
Subject: Re: [vpp-dev] issues with opensuse and centos verify job for 
stable/1801

hey matus,

 tl;dr:  https://gerrit.fd.io/r/11124 should get around this for now and future


This is because the newer version is not only installed but in some cases the 
repo ‘ledgers’ are older than whats currently installed.
(Due to the fact that I build the base build containers far more frequently 
than the openstack slaves are built).
So now ill trash anything that is installed and scrum the repo material clean 
so it thinks whatever is offered is latest and proper.

vanessa decided today was the day to smash her laptop so when she recovers ill 
get her to review and merge this up.

Ed






On Mar 13, 2018, at 9:13 AM, Matus Fabian -X (matfabia - PANTHEON TECHNOLOGIES 
at Cisco) <matfa...@cisco.com<mailto:matfa...@cisco.com>> wrote:

Hi,

I see issues with opensuse and centos verify jobs for stable/1801 branch.
The error is same for both jobs:
11:39:26 ########################################
11:39:27     package vpp-dpdk-devel-18.02-vpp1.x86_64 (which is newer than 
vpp-dpdk-devel-17.11-vpp1.x86_64) is already installed
11:39:27 make[1]: *** [install-rpm] Error 2
11:39:27 make[1]: Leaving directory `/w/workspace/vpp-verify-1801-centos7/dpdk'
11:39:27 make: *** [dpdk-install-dev] Error 2
11:39:27 Build step 'Execute shell' marked build as failure

See following patches:
https://gerrit.fd.io/r/#/c/11079/
https://gerrit.fd.io/r/#/c/11058/
https://gerrit.fd.io/r/#/c/11056/
https://gerrit.fd.io/r/#/c/11059/
https://gerrit.fd.io/r/#/c/11060/

Regards,
Matus Fabian


Reply via email to