On Thu, May 08, 2014 at 10:13:59PM -0700, Chad Versace wrote:
> On Sun, May 04, 2014 at 10:14:19AM -0700, Jordan Justen wrote:
> > These functions make it easier to compare against known OpenGL and
> > OpenGLES versions since all known and expected future versions have a
> > minor version <= 9.
> > 
> > For example, to check that the attrs struct has a version >= 3.2, use
> > wcore_config_attrs_version_above_or_equals(attrs, 32)
> > 
> > Signed-off-by: Jordan Justen <jordan.l.jus...@intel.com>
> > ---
> >  src/waffle/core/wcore_config_attrs.c | 48 
> > ++++++++++++++++++++++++++++++++++++
> >  src/waffle/core/wcore_config_attrs.h | 25 +++++++++++++++++++
> >  2 files changed, 73 insertions(+)
> 
> 
> > +wcore_config_attrs_version_equals(
> > +wcore_config_attrs_version_above(
> > +wcore_config_attrs_version_above_or_equals(
> > +wcore_config_attrs_version_below(
> > +wcore_config_attrs_version_below_or_equals(
> 
> The function names feel overly verbose. I prefer to rename them to
> 
>     wcore_config_attrs_version_eq
>     wcore_config_attrs_version_gt
>     wcore_config_attrs_version_ge
>     wcore_config_attrs_version_lt
>     wcore_config_attrs_version_le
> 
> But I don't want to block the series over it.
> 
> Renamed or not, this patch is
> Reviewed-by: Chad Versace <chad.vers...@linux.intel.com>

Oops, forgot something. Please prefix the patch subject as "core",
not "waffle internals". Take a quick look at the following to see the
pattern:

    git log src/waffle/core
    git log src/waffle/glx
    git log src/waffle/egl
    git log src/waffle/x11
_______________________________________________
waffle mailing list
waffle@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/waffle

Reply via email to