On 4 January 2015 at 22:02, Chad Versace <[email protected]> wrote: > The current wcore_attrib_list functions work on int32_t attribute lists. > A future commit will add variants that work on intptr_t attribute lists. > To prevent code duplication, this patch moves the definition of all > wcore_attrib_list32 functions into a type-generic macro, > WCORE_ATTRIB_LIST_COMMON_FUNCS, which will also be used to define the > upcoming intptr_t functions. > Despite that the approach looks great imho, I'm not 100% sure that MSVC will like the macros. Either way that will be addressed when it's confirmed that it causes an issue.
-Emil _______________________________________________ waffle mailing list [email protected] http://lists.freedesktop.org/mailman/listinfo/waffle

