Analogous to the WGL changes earlier.

Signed-off-by: Emil Velikov <emil.l.veli...@gmail.com>
---
 src/waffle/glx/glx_config.c | 9 ---------
 1 file changed, 9 deletions(-)

diff --git a/src/waffle/glx/glx_config.c b/src/waffle/glx/glx_config.c
index 7792aa0..58d241e 100644
--- a/src/waffle/glx/glx_config.c
+++ b/src/waffle/glx/glx_config.c
@@ -98,10 +98,6 @@ glx_config_check_context_attrs(struct glx_display *dpy,
             return true;
 
         case WAFFLE_CONTEXT_OPENGL_ES1:
-            assert(wcore_config_attrs_version_eq(attrs, 10) ||
-                   wcore_config_attrs_version_eq(attrs, 11));
-            assert(!attrs->context_forward_compatible);
-
             if (!dpy->EXT_create_context_es_profile) {
                 wcore_errorf(WAFFLE_ERROR_UNSUPPORTED_ON_PLATFORM,
                              "GLX_EXT_create_context_es_profile is required "
@@ -118,9 +114,6 @@ glx_config_check_context_attrs(struct glx_display *dpy,
             return true;
 
         case WAFFLE_CONTEXT_OPENGL_ES2:
-            assert(attrs->context_major_version == 2);
-            assert(!attrs->context_forward_compatible);
-
             if (!dpy->EXT_create_context_es_profile
                 && !dpy->EXT_create_context_es2_profile) {
                 wcore_errorf(WAFFLE_ERROR_UNSUPPORTED_ON_PLATFORM,
@@ -138,8 +131,6 @@ glx_config_check_context_attrs(struct glx_display *dpy,
             return true;
 
         case WAFFLE_CONTEXT_OPENGL_ES3:
-            assert(attrs->context_major_version == 3);
-
             if (!dpy->EXT_create_context_es_profile) {
                 wcore_errorf(WAFFLE_ERROR_UNSUPPORTED_ON_PLATFORM,
                              "GLX_EXT_create_context_es_profile is required "
-- 
2.8.0

_______________________________________________
waffle mailing list
waffle@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/waffle

Reply via email to