On 6 April 2016 at 16:59, Bas Nieuwenhuizen <b...@basnieuwenhuizen.nl> wrote:
> Signed-off-by: Bas Nieuwenhuizen <b...@basnieuwenhuizen.nl>
> ---
>  include/waffle/waffle.h              |  4 ++++
>  man/waffle_config.3.xml              | 24 ++++++++++++++++++++++++
>  src/waffle/core/wcore_config_attrs.c |  3 +++
>  src/waffle/core/wcore_config_attrs.h |  1 +
>  src/waffle/core/wcore_util.c         |  1 +
>  5 files changed, 33 insertions(+)
>
> diff --git a/include/waffle/waffle.h b/include/waffle/waffle.h
> index df0218e..b207f37 100644
> --- a/include/waffle/waffle.h
> +++ b/include/waffle/waffle.h
> @@ -142,6 +142,10 @@ enum waffle_enum {
>      WAFFLE_CONTEXT_DEBUG                                        = 0x0216,
>  #endif
>
> +#if WAFFLE_API_VERSION >= 0x106
> +    WAFFLE_CONTEXT_ROBUST_ACCESS                                = 0x0217,
> +#endif
> +
Silly me should have mentioned that we decided against using feature
(version) checks for the enums. Unless anyone feels otherwise I'd just
say go with the patch [as-is] and nuke any such checks in one go. Both
in the source and man pages.

-Emil
_______________________________________________
waffle mailing list
waffle@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/waffle

Reply via email to