Dear Alpin Novianus Tatan,

thank you for your swift reply!
This indeed solved my issue, thanks a lot.

I also did not know about the searchable mailing list, and while Google 
sometimes finds the appropriate answers in the archive, it unfortunately did 
not in this case. Next time I will check it before mailing a question.

Best regards,

Carl-Friedrich Schön,
RWTH Aachen University

Von: Alpin Novianus<>
Gesendet: Dienstag, 1. Juni 2021 16:35
An: Schön, Carl-Friedrich<>
Betreff: Re: [Wannier] Error 144, wrong number of kpoints

Dear Carl-Friedrich Schön,

I encountered a similar error previously.
I fixed my problem by always having nosym = .true. when running nscf for 
wannierization. I believe someone else also had this problem and asked this 
question and got an answer in this mailing list before. (I found my solution by 
searching the list)

The symmetry setting in pwscf adds and reduces the number of k-points, so the 
resulting k-point number is different from the number we pass in the input file.
(Even though you put 144 points, it'll add/reduce some more).
If you set nosym = true, this switches off the symmetry setting so you only get 
what you write in the input file.

I hope this solution helps your problem.

I also wish this "nosym = .true." trick can be added by the admins in the 
wannier90 userguide so that no one else got confused by the same problem.

Here is also the searchable Wannier90 Mailing List.

Somehow, this link is not shown in the Wannier90 website.
I hope the admins will add it to appear here:

New users may not be able to find the search page from the link shown here:
which shows only the monthly archive but there is no obvious way to find the 
searchable page I put above.

Best regards,
Alpin Novianus Tatan
University of Tokyo

On Tue, Jun 1, 2021 at 11:11 PM Schön, Carl-Friedrich 
<<>> wrote:
Dear experts,

I have a problem running wannier90, which only occurs sporadically. I hence 
assume it is some problem with inconsistent symmetry operations:

Wannier mode is: standalone

  *** Reading nnkp
  Checking info from wannier.nnkp file
  - Real lattice is ok
  - Reciprocal lattice is ok
  Something wrong!
  numk=         144  iknum=         360

     Error in routine pw2wannier90 (144):
     Wrong number of k-points

     stopping ...

The order I run the steps in is:

pw.x <<> | tee result.scf.out
pp.x <<>

pw.x <<> | tee ncpp.nscf.out
pw2critic.x <<>

wannier90.x -pp
$MPIEXEC $FLAGS_MPI_BATCH pw2wannier90.x <<>

For the k-points of the scf calculation, I usually use an automatic grid, e.g.

K_POINTS automatic
6 6 4 0.0 0.0 0.0

While for the nscf calculation I use an exlicit list of k-points:

K_POINTS crystal
  0.00000000  0.00000000  0.00000000  6.944444e-03
  0.00000000  0.00000000  0.25000000  6.944444e-03

I also tried to use the explicit list in the scf calculation, but that did not 
help. reads:

num_iter=10000 ! default: 100

begin projections
end projections

#search_shells = 24 ! default: 12
kmesh_tol = 1d-4 ! default: 1d-6
mp_grid : 6 6 4
begin unit_cell_cart
8.6888 0.0 0.0
-4.3444 7.5247 0.0
0.0 0.0 13.7208
end unit_cell_cart
begin atoms_frac
Mg 0.0 0.0 0.0
Mg 0.3333 0.6667 0.3678
Mg 0.6667 0.3333 0.6322
Sb 0.3333 0.6667 0.7747
Sb 0.6667 0.3333 0.2253
end atoms_frac
begin kpoints
  0.00000000  0.00000000  0.00000000  6.944444e-03
  0.00000000  0.00000000  0.25000000  6.944444e-03
…. (with the correct number of 144 kpoints listed here)

While<> just reads:


Has anyone encountered this error already and/or knows how to fix it? Any 
suggestions are welcome!

Thanks a lot and best regards,

Carl-Friedrich Schön (PhD student),
RWTH Aachen University, Germany
Wannier mailing list<>
Wannier mailing list

Reply via email to