On Fri, 9 May 2008 12:05:47 +0200, Dennis Schridde <[EMAIL PROTECTED]>
> widget.h:
> int32_t userData;

I made it a fixed size so that people would not be tempted to store
pointers in it (we have pUserData for that). Knowing it is a fix size may
also allow it to be used for storing floating-point values.

> That is the size of the userData blob?
> Why does it need to be exactly 32bit long?
> Maybe size_t would be a good type?
> And userDataSize a better name?

size_t would be fine, also. Just so long as people will not store pointers
in it I am happy.

Regards, Freddie.

Warzone-dev mailing list

Reply via email to