#93: configure can't find openal on my machine
---------------------------------------+------------------------------------
        Reporter:  [EMAIL PROTECTED]  |        Type:  defect      
          Status:  new                 |    Priority:  major       
       Milestone:                      |   Component:  Build system
         Version:  2.1_beta5           |    Keywords:              
Operating_system:  GNU/Linux           |  
---------------------------------------+------------------------------------
 I am using slackware 12.1 on a 32bit x86 machine.

 Despite the fact I have openal 0.0.8 installed configure in beta 5 cannot
 find it and throws a bizzare error message:

 checking for OPENAL... configure: error: Package requirements (openal >=
 0.0.8) were not met:

 Package @requirements@ was not found in the pkg-config search path.
 Perhaps you should add the directory containing [EMAIL PROTECTED]@.pc'
 to the PKG_CONFIG_PATH environment variable
 Package '@requirements@', required by 'OpenAL', not found

 I think this is a bug in configure.in, but I can't really do any testing
 of it since I can't run autogen.sh - my distribution does not supply auto*
 tools new enough to bootstrap the build system.

 This problem seems to be similar to one noted in the message below from a
 different open source project. I've supplied a link to the diff as well.
 As I said, I can't test this since I can't run autogen.sh - so I have no
 idea if this is the problem or just happens to look similar.

 http://osdir.com/ml/netbsd.devel.pkgsrc.user/2006-10/msg00323.html and the
 patch:
 
http://enlightenment.cvs.sourceforge.net/enlightenment/e17/libs/imlib2/configure.in?r1=1.86&r2=1.87&diff_format=u

-- 
Ticket URL: <http://developer.wz2100.net/ticket/93>
Warzone 2100 Trac <http://wz2100.net/>
The Warzone 2100 Resurrection Project
_______________________________________________
Warzone-dev mailing list
Warzone-dev@gna.org
https://mail.gna.org/listinfo/warzone-dev

Reply via email to