I opened up a ticket with your suggestion. Would you mind updating it 
with your latest code?
http://jira.openqa.org/browse/WTR-262


Tony wrote:
> Was running the tests for some time .. and suddenly i started getting
> wrong results for visible.
> Look like the #{element_object} was returning null sometimes. Dont
> know why....
> Started working after adding assert_exists
> Heres the updated code -
>
> class Element
> def visible?
>  assert_exists
>  jssh_command = "var val = 'true'; var str = ''; var obj =
> #{element_object}; while (obj != null) { try { str =
> document.defaultView.getComputedStyle(obj,null).visibility; if
> (str=='hidden') { val = 'false'; break; } str =
> #{DOCUMENT_VAR}.defaultView.getComputedStyle(obj,null).display; if
> (str=='none') { val = 'false'; break; }  } catch(err) {} obj =
> obj.parentNode; } val;"
>  jssh_socket.send("#{jssh_command}\n", 0)
>  vals = read_socket()
>  return (vals == 'false')? false: true
> end
> public:visible?
> end
>
>
> >
>   


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Watir General" group.
To post to this group, send email to watir-general@googlegroups.com
Before posting, please read the following guidelines: 
http://wiki.openqa.org/display/WTR/Support
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/watir-general
-~----------~----~----~----~------~----~------~--~---

Reply via email to