Or you can use Ruby 1.8.6 and Watir 1.6.2. The modal dialog support has 
been updated to work with Ruby 1.8.6.

Alex Collins wrote:
> For the rails aspect, you should probably search / ask a rails group. 
>
> However, you should be able to install two versions of ruby - and use 
> a custom PATH variable for the command window you start watir in to 
> point to the older version on ruby. You will obviously need to ensure 
> that you Use the correct ruby installs when installing gems etc.
>
> Eg
> Set PATH=c:\old-ruby\bin;%PATH%
>
> Hope this helps.
>
> Alex  
>
> On 11 Nov 2008, at 05:26, "pramod D" <[EMAIL PROTECTED] 
> <mailto:[EMAIL PROTECTED]>> wrote:
>
>>
>>
>> Hi All,
>> My application runs only on IE and uses lots of modal window for this 
>> reason i have installed Ruby 1.8.2, and now i am  trying to  install  
>> Rails 1.2.3, but throws  error and it is expecting  Ruby 1.8.5 . Can 
>> any body tell me  what version of Rails i need to install . Its very 
>> urgent kindly help me.
>>
>> Error i got is:- ERROR:  While executing gem ... (RuntimeError)
>>     rails-toolkit requires Ruby version >= 1.8.5
>>
>> Thanks,
>> Pramod.D
>>
>>
>
> >


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Watir General" group.
To post to this group, send email to watir-general@googlegroups.com
Before posting, please read the following guidelines: 
http://wiki.openqa.org/display/WTR/Support
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/watir-general
-~----------~----~----~----~------~----~------~--~---

Reply via email to