Thank you for figuring out how to get Watir working (again) with cygwin. 
If you could put this in Jira, then we'll be sure to look at fixing this 
in the next release.

Bret

Arco wrote:
> On Cygwin, I ran into two separate problems that prevented Watir 1.6.2
> from working.
>
> First, the 'win32ole.so' file that ships with Watir appears to be
> incompatible with the version that is installed with my copy of Cygwin-
> ruby. (see http://pastie.org/374756)
>
> An error message 'bad file permissions' was generated when trying to
> run  'x = Watir::IE.new' from within IRB.
>
> My workaround was to copy the 'ruby' version of win32ole.so into the
> 'watir' directories.  (see http://pastie.org/374865)
>
> Once this was done, another error occured - relating to modal
> dialogs.  (see http://pastie.org/374865)
>
> This was fixed by commenting out 2 lines in the Watir source code:
>
>     File - modal_dialog.rb    Line - 65           GetUnknown.call ...
>     win32.rb:6 GetUnknown = Win32API.new(...
>
> Once these lines were commented out, watir worked.
>
> Ideas for fixes:
> - Fix the modal dialog issue with conditional execution:
>             GetUnknown.call (...) unless  RUBY_PLATFORM == 'i386-
> cygwin'
>             GetUnknown=Win32APUI.new(...   unless RUBY_PLATFORM ==
> 'i386-cygwin'
> - Fix the win32ole issue by not bundling this file in the gem (??)
> - Cygwin support:
>               either fully commit to supporting cygwin, or not
>                I think it should be supported!!!
>                run regression tests on cygwin before every release
> >
>   


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Watir General" group.
To post to this group, send email to watir-general@googlegroups.com
Before posting, please read the following guidelines: 
http://wiki.openqa.org/display/WTR/Support
To unsubscribe from this group, send email to 
watir-general-unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/watir-general
-~----------~----~----~----~------~----~------~--~---

Reply via email to