Jasmin,

Put this in a file, two-minute.rb, and run "ruby two-minute.rb" on it.

require "watir"

ie = Watir::Browser.new

ie.goto "http://www.google.com";

ie.text_field(:name, "q").set "WSO2 WSAS"

ie.button(:name, "btnG").click

Call me on Google Talk if you have problems.

Thanks,
Al

On Feb 5, 1:59 pm, Jaz <jasmin.chazarr...@gmail.com> wrote:
> HI again!
>
> I have now tried both
>  gem install win32-api
>  gem install win32-process
>  gem install windows-pr
>
> and
>  gem update win32-api
>  gem update win32-process
>  gem update windows-pr
>
> This is really confusing....
>
> Here is the complete text in the prompt:
>
> C:\Documents and Settings\JasminC>irb
> irb(main):001:0> require "watir"
> => true
> irb(main):002:0> ie = Watir::IE.new
> Win32::API::Error: Attempt to format message failed
>         from C:/Ruby/lib/ruby/gems/1.8/gems/windows-api-0.3.0/lib/
> windows/api.rb
> :333:in `initialize'
>         from C:/Ruby/lib/ruby/gems/1.8/gems/windows-api-0.3.0/lib/
> windows/api.rb
> :333:in `new'
>         from C:/Ruby/lib/ruby/gems/1.8/gems/windows-api-0.3.0/lib/
> windows/api.rb
> :333:in `initialize'
>         from C:/Ruby/lib/ruby/gems/1.8/gems/windows-pr-0.9.9/lib/
> windows/msvcrt/
> string.rb:35:in `new'
>         from C:/Ruby/lib/ruby/gems/1.8/gems/windows-pr-0.9.9/lib/
> windows/msvcrt/
> string.rb:35
>         from C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `ge
> m_original_require'
>         from C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `re
> quire'
>         from C:/Ruby/lib/ruby/gems/1.8/gems/windows-pr-0.9.9/lib/
> windows/unicode
> .rb:2
>         from C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `ge
> m_original_require'
>         from C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `re
> quire'
>         from C:/Ruby/lib/ruby/gems/1.8/gems/win32-process-0.6.0/lib/
> win32/proces
> s.rb:9
>         from C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `ge
> m_original_require'
>         from C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `re
> quire'
>         from C:/Ruby/lib/ruby/gems/1.8/gems/watir-1.6.2/lib/watir/ie-
> process.rb:
> 1
>         from C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `ge
> m_original_require'
>         from C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
> 31:in `re
> quire'
>         from C:/Ruby/lib/ruby/gems/1.8/gems/watir-1.6.2/lib/watir/
> ie.rb:45
>         from (irb):2irb(main):003:0>
>
> Im really new with this, sorry for taking your time but I really need
> to learn and use Watir...
>
> Regards
> Jasmin
>
> On 5 Feb, 17:31, aidy lewis <aidy.le...@googlemail.com> wrote:
>
> > Your right Charley
>
> > gem install windows-pr
>
> > Will do it.
>
> > Aidy
>
> > 2009/2/5 Charley Baker <charley.ba...@gmail.com>:
>
> > > It seems there are some compatibility issues here with some of the
> > > win32utils. Try updating your win32-api gem, win32-process and the
> > > windows-pr gem as well.  Same instructions that Aidy mentioned before with
> > > those gems.
>
> > > Charley Baker
> > > blog:http://charleybakersblog.blogspot.com/
> > > Lead Developer, Watir,http://wtr.rubyforge.org
> > > QA Architect, Gap Inc Direct
>
> > > On Thu, Feb 5, 2009 at 6:51 AM, aidy lewis <aidy.le...@googlemail.com>
> > > wrote:
>
> > >> This will work
>
> > >>  require 'watir'
> > >>  Watir::Browser.default = "ie"
> > >> �...@browser ||= Watir::Browser.new
>
> > >> Aidy
>
> > >> 2009/2/5 Jaz <jasmin.chazarr...@gmail.com>:
>
> > >> > Hi!
>
> > >> > Thanks for answering so fast Aidy
> > >> > Unfortuneatly it still doesn't work =(
>
> > >> > (Going crazy soon...)
>
> > >> > /jasmin
>
> > >> > On Feb 5, 1:59 pm, aidy lewis <aidy.le...@googlemail.com> wrote:
> > >> >> gem list -r win*
>
> > >> >> gem update windows-api -y
>
> > >> >> Aidy
>
> > >> >> 2009/2/5 Jaz <jasmin.chazarr...@gmail.com>:
>
> > >> >> > How do I do that?
>
> > >> >> > On Feb 5, 12:36 pm, aidy lewis <aidy.le...@googlemail.com> wrote:
> > >> >> >> At a guess try updating your windows api gem
>
> > >> >> >> Aidy
>
> > >> >> >> 2009/2/5 Jaz <jasmin.chazarr...@gmail.com>:
>
> > >> >> >> > Hi!
>
> > >> >> >> > Recently installed ruby to use watir, and I get a strange error
> > >> >> >> > when I
> > >> >> >> > execute the steps in "Watir in 5 minutes"
> > >> >> >> >http://wiki.openqa.org/display/WTR/Watir+in+5+Minutes
>
> > >> >> >> > These are the steps I follow:
>
> > >> >> >> > 1. require "watir"
>
> > >> >> >> > 2. ie = Watir::IE.new
>
> > >> >> >> > When I perform step 2 I get the following error:
>
> > >> >> >> > Win32::API::Error: Attempt to format message failed
> > >> >> >> > from 
> > >> >> >> > C:/Ruby/lib/ruby/gems/1.8/gems/windows-api-0.3.0/lib/windows/
> > >> >> >> > api.rb:333 in 'initialize'
> > >> >> >> > from 
> > >> >> >> > C:/Ruby/lib/ruby/gems/1.8/gems/windows-api-0.3.0/lib/windows/
> > >> >> >> > api.rb:333 in 'new'
> > >> >> >> > .
> > >> >> >> > .
> > >> >> >> > .
> > >> >> >> > .. and the message continues.
> > >> >> >> > I can write the whole message down if necessary. It's really long
> > >> >> >> > =(- Hide quoted text -
>
> > >> >> >> - Show quoted text -- Hide quoted text -
>
> > >> >> - Show quoted text -- Dölj citerad text -
>
> > - Visa citerad text -
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Watir General" group.
To post to this group, send email to watir-general@googlegroups.com
Before posting, please read the following guidelines: 
http://wiki.openqa.org/display/WTR/Support
To unsubscribe from this group, send email to 
watir-general-unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/watir-general
-~----------~----~----~----~------~----~------~--~---

Reply via email to