I am a newbie to firewatir. I am having an issue in clicking a link.
I tried to test a watir script in firefox for which i installed
firewatir 1.6.2.
I have now created firefox instance instead of the existing IE
instance.
My web application is successfully logged in and then I want to click
a link in that page, but am getting the following error:

c:/ruby/lib/ruby/gems/1.8/gems/firewatir-1.6.2/lib/firewatir/
MozillaBaseElement.rb:967:in `assert_exists': Unable to locate
element, using :text,
"balances" (Watir::Exception::UnknownObjectException)
        from c:/ruby/lib/ruby/gems/1.8/gems/firewatir-1.6.2/lib/firewatir/
MozillaBaseElement.rb:1112:in `click'

The following is the code:
require 'firewatir'
include FireWatir
ff=Firefox.new
$ie =ff.goto("http://10.65.4.111/ocsecurities/";)
$ie.frame("main").text_field(:name,"loginId").set("AU972705")
$ie.frame(:name,"main").text_field(:name,"password").set("nexa123")
$ie.frame(:name,"main").button(:name,"OK").click
$ie.frame("main").link(:name,"balances").click

I am getting this error in the last line.
Please help me in fixing this issue.

Thanks in advance.

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Watir General" group.
To post to this group, send email to watir-general@googlegroups.com
Before posting, please read the following guidelines: 
http://wiki.openqa.org/display/WTR/Support
To unsubscribe from this group, send email to 
watir-general-unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/watir-general
-~----------~----~----~----~------~----~------~--~---

Reply via email to